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Глава 2

Редактор топологии EMSight 

Проект MWO состоит из частей, описанных как электрические схемы, подсхемы, текстовые файлы, а также блоки, анализируемые, используя электродинамический метод расчета. Эта особенность MWO переводит проектирование СВЧ устройств на более высокий качественный уровень, по сравнению с программами Touchstone, Libra, MMICAD, и др., использующими методы, основанные на объединении матриц, каждая из которых рассчитывается методами теории цепей.

Если в проекте используется только схема, то в программе MWO также применяются методы теории цепей (или метод Олинера, если в моделях учитываются неоднородности, неизбежно имеющиеся в местах соединения элементов). Другой метод расчета, используемый в MWO для СВЧ структур, является электродинамическим и реализован в подпрограмме, имеющей название EMSight. В этой главе мы покажем, как создается часть схемы, рассчитываемая как EM структура. 

Для создания и редактирования элементов дерева проекта Вы должны дважды нажать на соответствующем пункте в дереве просмотра или использовать правую кнопку мыши (рис. 2.1).
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Рис. 2.1. Создание новой EM структуры как части проекта, в которую входят схемы, подсхемы

Чтобы создать новую структуру, анализируемую электродинамическим методом моментов, выбирается команда New EM Structure. После этого появляется объем, в котором задаются материалы заполнения этого объема и слои, на которых можно нанести все необходимые металлические формы.

2.1. Редактирование геометрии структуры

EMSight. имеет графический редактор, в котором возможен просмотр структур в двух- и трехмерном виде. 

Двухмерный просмотр топологии
[image: image2.wmf]
 На рабочем столе могут быть открыты несколько 2-мерных видов, если выбрать команду View>2D View из меню или из инструментальной линейки.
Трехмерный просмотр конструкции
[image: image3.wmf]
 Просмотр трехмерного представления конструкции выполняется командой View>3D View. Возможна активизация 2- и 3-мерного просмотра той же самой структуры. Объект в трехмерном просмотре можно вращать, щелкая мышью в поле объекта и перемещая ее. 

Представление конструкции связано с понятиями диэлектрических слоев и уровней. Причем номера слоев и уровней (Layer) одинаковы при просмотре слоя сверху, как принято при двумерном просмотре топологии. Каждый нарисованный слой соответствует одному из диэлектрических слоев в металлическом корпусе. Активный слой - это текущий слой, на котором могут наноситься металлические структуры произвольной формы. Диэлектрический слой, который соответствует активному слою чертежа, окрашен при трехмерном просмотре сиреневым цветом. 

Уровень 1 - верхняя крышка корпуса (рис. 2.2, 2.4). Номера уровней и соответствующих им слоев увеличиваются при продвижении к нижним слоям. Число слоев и толщина каждого слоя задаются в диалоге Substrate Information (информация о подложке), к которому обращаются из меню Structure > Enclosure. Для очень тонкого или очень толстого слоя в этом меню можно установить более удобный масштаб просмотра.

2.2. Редактирование параметров корпуса

[image: image4.wmf]
 Реквизиты корпуса включают габариты и заполнение (структуру) прямоугольного корпуса. Чтобы изменить эти габариты, сделайте двойной щелчок на пункте Enclosure в дереве проекта. Появляется диалог Substrate Information, в котором задаются и редактируются параметры корпуса, слое и граничных условий (см. рис. 2.2). Диалоговое окно Subsrate Information имеет 3 закладки:

· Enclosure (замыкающий корпус);

· Dielectric Layers (диэлектрические слои);

· Boundaries (границы).

Размер корпуса задается на первой странице диалога Enclosure. Общая высота корпуса не устанавливается, потому что она определяется суммарной толщиной  всех диэлектрических слоев, которые устанавливаются на второй странице в диалоге Substrate Information. 
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                       Рис.2.2. Каждый слой разбит на 32 ячейки по координатам X  и  по Y (размер ячейки  20(20 мкм)
Box Dimensions - размеры корпуса;  
X-Dimension  - размер по оси X; Y-Dimension - размер по оси Y;
X-Division - количество разбиений по оси X; Y-Division - количество разбиений по оси Y;
Cell Size  - размер ячейки в единицах длины, устанавливаемой в блоке Units
Все формы, металлические и диэлектрические, которые заданы в EMSight, должны совпасть с сеткой чертежа. Вы можете вводить формы, которые не совпадают с этой сеткой, но после отпускания мыши или при перетаскивании формы EMSight автоматически совместит координаты формы с основной сеткой. Густота сетки определяется числом делений в направлениях X и Y. Моделирование выполняется быстрее, если число делений будет каким-то числом в степени 2 (т. е. равным 32, 64, 128 и т. п.). Если используется режим FFS (Fast Frequency Sweep), число делений должно быть четным. Число делений и размеры ячейки могут не быть одинаковыми по направлениям X и Y (рис. 2.3). Размер ячейки в каждом направлении соответствует размеру корпуса в этом же направлении, разделенному на число делений. Важно отметить, что для всех слоев используется одна и та же сетка.
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Рис. 2.3.  Нанесение узлов сетки на слое (16 делений по осям X и Y)
Размер ячейки, который должен использоваться для определенной задачи, определен конкретным числом разбиений. Ячейки с меньшими размерами обеспечивают более точное моделирование, но требуют больших затрат времени на решение. Первоначально рекомендуется использовать самый большой размер ячейки, который достаточно точно аппроксимирует геометрию. Далее, на последующих этапах моделирования, размер ячеек можно уменьшать, увеличивая число разбиений корпуса. 
2.3. Диэлектрические слои

Диэлектрические слои устанавливаются в закладке Dielectric Layers. Корпус содержит минимум два диэлектрических слоя. Самый верхний диэлектрический слой – Layer 1. Связь между уровнями чертежа и диэлектрическими слоями показан на рис. 2.4.
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Рис. 2.4. Соотношение между слоями и уровнями на чертеже конструкции
Часто верхний слой задается как воздушный слой, хотя это необязательно. К параметрам диэлектрических слоев относятся его толщина (Thickness), относительная диэлектрическая проницаемость ((r), тангенс диэлектрических потерь (Loss Tangent). 
Таблица 2.1. Материалы диэлектрической подложки
	Материал
	(r
	Тангенс диэлектрических потерь

	Воздух
	1.0
	0

	Поликор
	9.8
	<0.0015

	Кварц
	3.78
	<0.0001

	Кремний
	11.9
	~0.003

	Арсенид галлия
	12.9
	0.001

	RT Duroid 5880
	2.20
	<0.0009

	RT Duroid 5870
	2.33
	0.0012

	RT Duroid 6006
	6.15
	0.0019


Параметры подложки можно найти в справочниках. В предварительных расчетах можно использовать данные, приведенные в табл. 2.1.

   Потери электромагнитной энергии в конструкции зависят как от потерь в подложке, так и от потерь в металлических проводниках. Неидеальность границ корпуса можно установить в закладке Boundaries. Эта закладка (рис. 2.5) имеет две части, задающие модели верха и модели нижней границы корпуса.

Опция Perfect conductor (Идеальный проводник) моделирует верхнюю или нижнюю границы корпуса как идеальный проводник без потерь.
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Рис. 2.5. Диалоговое окно установки границ вверху и внизу корпуса

Опция Specify material (Спецификация  материала) позволяет задать свойства материала подложки, аналогично тому, как это делается для проводящих материалов (см. рис. 2.6). Сначала в проекте создают материал с желаемыми параметрами. Как только материал определен, его можно использовать в проекте: например, он может быть назначен границе корпуса, выбирая его в Draw > Edit Shape Props из списка доступных материалов.
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Рис. 2.6. Диалоговое окно установки и модификации свойств материала

Использование опции Approximate open (открытый конец) эквивалентно заданию границы как материала, который имеет удельное сопротивление постоянному току 377 Ом, что приблизительно равно волновому сопротивлению свободного пространства. При моделировании открытой границы верхняя крышка должна быть расположена достаточно далеко от схемы, чтобы в любой точке поля, излучаемого схемой, не было значительного взаимодействия с границей. Использование для границы сопротивления 377 Ом – это приближение для свободного пространства, что обеспечивает достаточную точность для большинства задач. Этот режим используется при анализе типовой структуры антенны (рис. 2.7). 
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Рис. 2.7. Крышка и дно корпуса, разделенного на два слоя
При включении опции Infine waveguide верхний (или нижний) слой моделируется как бесконечно длинный волновод, заполненный тем же самым диэлектриком, что и верхний или нижний слой. Бесконечная граница волновода может использоваться для моделирования волноводно-микрополоскового перехода.

2.4. Формы проводника
Выбор активного слоя чертежа
Активный слой чертежа может быть изменен,  выбирая закладку слоя в нижней части окна 2-мерного просмотра структуры. 

Выбор формы проводника
Чтобы выделить форму проводника, нажмите клавишей мыши на его рисунок. Чтобы выбрать одновременно несколько форм, удерживайте при этом клавишу Shift. По другому несколько форм можно выбрать, охватывая  их пунктирным прямоугольником. 

Чтобы выбрать форму, которая находится ниже данной, удерживайте клавишу Ctrl и нажмите на нее несколько раз, пока нужная форма не будет выбрана.

Замораживание неактивных слоев
Когда неактивные уровни заморожены, только формы на текущем слое могут быть выделены или отредактированы. Выбор в меню или на инструментальной линейке команды Draw>Freeze Non-Active Layers позволяет прокладывать перемычки между слоями и снимать замораживание.
Последовательная отмена создания конструкции и операция восстановления
При редактировании проекта выполненную операцию можно отменить, выбирая команды Edit>Undo или Edit>Redo, причем это можно делать многократно.

Черчение проводников
Планарные проводники могут размещаться на любом слое (хотя плоские проводники не могут быть передвинуты на слой 1, который совпадает с крышкой корпуса). Чтобы прибавить к проекту новый планарный проводник, сначала выберите активный уровень,  щелкая на закладке в нижней части диалога двухмерного просмотра. Плоский проводник может быть добавлен, используя одну из команд меню или инструментальных средств чертежа.

Добавление проводников
Если в проекте на каком-нибудь слое нужно добавить проводник, выбирают команду Draw >Add, щелкая левой кнопкой мыши в месте будущей вершины проводника и дважды нажимая на последнюю точку, чтобы создать проводник.

Добавление проводника прямоугольной формы
Чтобы добавить проводник прямоугольной формы, выберите команду Draw >Add   Rect Conductor, нажимая левую кнопку мыши, и используйте мышь для рисования этого прямоугольника.

Редактирование проводников
Чтобы изменить форму проводника, дважды щелкните на нем мышью, чтобы перевести его в «режим редактирования». В этом режиме на каждой вершине и в середине каждой стороны появляются черные квадратики, захватывая которые можно растянуть форму (рис. 2.8). Можно использовать также несколько команд меню или инструментов черчения, чтобы редактировать форму проводника.
[image: image11.wmf]
Рис. 2.8. Редактирование проводника произвольной формы
Проводник с канавкой (вырезом, пазом)
Чтобы сделать вырез в проводнике, сначала активизируйте его и затем выберите команду Draw > Notch Conductor. Нажмите левую кнопку мыши и переместите ее, чтобы нарисовать прямоугольник паза, и после этого канавка замкнется. Введение выреза внутри корпуса проводника прибавит к проводнику прямоугольную площадку. Ввод паза снаружи приведет к вычитанию этой площадки.

Растяжение площадки
Сначала выбирается форма, которую нужно растянуть, после чего выбирается команда Draw > Stretch Area  из меню или инструментальной панели. В каждой вершине выбранной формы изображается полый квадратик. Нажмите левую кнопку мыши на нужном квадратике, чтобы выбрать его для растяжения. Чтобы выбрать несколько вершин, нажмите левую кнопку мыши снаружи форм и охватите пунктирным прямоугольником точки, которые хотите выбрать. Чтобы отказаться от выбора узла, нажмите клавишу Shift при щелчке или перемещении. Когда желаемая вершина выбрана, нажмите левую кнопку мыши на одной из точек, и перетащите мышь, чтобы растянуть форму за выбранные точки.

После каждого сеанса растяжения лишние точки удаляются, также как и формы с нулевой площадью. 

Перемещение проводника
Чтобы перемещать выбранные формы, нажмите на них левой кнопкой мыши, перетащите мышью.

Для копирования выбранных форм в буфер, выполните команду Edit > Copy.
Чтобы отрезать часть проводника и переместить его в буфер, выберите

команду Edit > Cut.

Чтобы вставить выбранные объекты из буфера обмена в проект, выберите команду Edit >Paste. Объекты из буфера обмена могут вставляться в тот же самый или в другой документ того же типа. 

После выбора Edit >Paste объекты для вставки появляются в текущей точке, помеченной курсором. Для удаления выбранных форм выполняют команду Edit > Delete. 

Чтобы выполнить вращение выбранных объектов, используйте команду Draw > Rotate. Нажмите левую кнопку в точке вращения, затем перетащите мышь, чтобы определить  угол поворота, и отпустите ее. Или щелкните правой кнопкой мыши на вершине выбранной формы, и в появившемся меню запустите команду Draw > Rotate.

Для зеркального отражения выбранных объектов выполните  команду Draw > Flip. Нажмите левую кнопку мыши в установленной точке относительно линии отражения, затем перетащите мышь, чтобы обозначить горизонтальную или вертикальную ось отражения.

Выбранные объекты могут перемещаться на другие уровни (слои) подложки по  команде Draw > Move Up One Layer или Draw > Move Down One Layer.

Привязка проводящей формы к сетке
Чтобы привязать линии и узлы проводящей формы к сетке, выберите команду Draw > Snap Shape.

Узлы сеток
Чтобы сделать привязку проводника к сетке,  выполните команду  Draw >Grid Snap.

Режим  ортогонального черчения
Команда Draw > Orthogonal ограничивает проведение линий ортогональными направлениями.

Измерение расстояния
Чтобы измерить расстояние в 2D режиме, выберите в меню команду Draw >Measure, а затем нажмите левую кнопку мыши в начальной точке измеряемой линии. Перетащите мышь, чтобы растянуть линейку и измерить расстояние. 

2.5. Реквизиты проводников 

Характеристики материалов

Для каждого проводника в графе Material Conductor (материал проводника) указываются потери в нем. Проект может иметь несколько объектов Material Conductor. Характеристики проводящих материалов приведены в табл. 2.2.

Таблица 2.2. Проводимости материалов

	Материал
	Проводимость

	Silver (серебро)
	6,14 ( 107

	Copper (медь)
	5,88 (107

	Gold (золото)
	4,10 (107

	Aluminum (алюминий)
	3,53 (107

	Nickel (никель)
	1,47 (107


Чтобы изменить спецификацию материала или реквизиты проводника, выберите его, а затем выполните команду Draw >Edit Shape Props  для редактирования (сделайте правый щелчок на форме, и затем из всплывающего меню выберите строку Edit Shape Props, после чего появится диалог  рис. 2.9). Каждый материал должен иметь уникальное имя. Электрические реквизиты проводников могут иметь электрические параметры или параметры материала. 
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Рис. 2.9. Диалог задания параметров материалов, используемых в проекте

Электрические параметры. Сопротивление проводника постоянному току (ом на квадрат) определяется по формуле
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где ( – проводимость проводника, t – его толщина. 
Коэффициент высокочастотных потерь High frequency loss coefficient определяет потери проводника на частотах, где толщина проводника значительно больше, чем глубина поверхностного слоя. Так как потери, связанные со скин-эффектом, пропорциональны квадратному корню частоты, коэффициент потерь глубины поверхностного слоя умножается на квадратный корень частоты. Коэффициент высокочастотных потерь:
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(2.2)

На низких частотах сопротивление RDC используется при оценке потерь проводника, в то время как на высоких частотах для оценки потерь используется RHF. При расчете на СВЧ (частотах, где глубина поверхностного слоя близка к толщине проводника) учитываются оба фактора.

Поверхностное реактивное сопротивление Excess surface reactance (поверхностный реактанс) используется, чтобы моделировать реактивное сопротивление, связанное со сверхпроводимостью. Для обычных проводников оно не используется.

Альтернативный (и более простой) метод определения электрических параметров материалов состоит в том, чтобы вводить их как параметры материалов и использовать EMSight для получения их электрических параметров. Чтобы точно определить параметры материалов, должны быть определены толщина и проводимость проводника. 

Потери, вычисленные на основе  параметров материалов, присваиваются идеальному проводнику. Примеси и шероховатость поверхности имеют тенденцию делать измеряемые потери несколько выше, чем моделируемые потери. Один способ для согласования состоит в уменьшении проводимости (обычно на 10 - 20 %) проводника, так что моделируемые потери согласуются более близко с измеряемыми потерями. Измеренные потери  линии передачи могут быть согласованы с моделируемыми данными той же самой линии,  итерационно регулируя «эффективную» проводимость проводника. Эту «действительную» («эффективную») проводимость можно затем использовать вместо идеальной проводимости для проводника.

2.6. Перемычки

Перемычки Via используются для межсоединения проводящих форм на различных слоях, и для подсоединения проводников к нижнему и верхнему слоям. Типичная перемычка, используемая для подключения линии к нижнему слою, показывается ниже слева. Перемычка, используемая для соединения проводников на различных слоях, показывается ниже справа (рис. 2.10).
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Рис. 2.10. Расположение перемычек между слоями

Добавление перемычек

[image: image16.wmf] Перемычка, соединяющая два слоя, всегда начинается от верхнего слоя вниз. Чтобы добавить перемычку, сначала активизируют верхний слой, выбирая закладку слоев. Затем выбирают Draw > Add Via, нажимая левую кнопку мыши, перетаскивают мышь, чтобы нарисовать прямоугольник (рис. 2.11). Таким образом, на слое рисуется форма, в виде прямоугольника, которая является сечением перемычки.
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Рис. 2.11. Включение перемычек

Как только перемычка введена, можно отредактировать присоединенный к ней проводник. Перемычка должна иметь ширину не менее размера одной ячейки. Длина перемычки равна толщине диэлектрического слоя. Если перемычка соединяет проводники больше, чем через один слой, перемычки рисуются сверху каждого диэлектрического слоя, через который должна пройти перемычка. Верхняя и нижняя граница перемычки замыкают проводящие формы как обычные плоские проводники, так что нет необходимости накладывать соединяющий планарный проводник. Ток, который идет через перемычку, моделируется как однороднонаправленный объемный ток. Одно из предположений, требуемых для моделирования перемычки - то, что длина перемычки (равная толщине диэлектрического слоя) короче длины волны. Если геометрия структуры получается такая, что длина перемычки стала соизмерима с длиной волны, то подложка может быть разбита на отдельные «более короткие» слои так, что перемычка будет состоять из отдельных более коротких перемычек, помещенных в стык друг к другу.

2.7. Порты
Порты – это две клеммы, которые используются для моделирования ввода СВЧ мощности в структуру и вывода ее из структуры. Физически порт представляет собой источник напряжения, который возбуждает ток в структуре. Ток находится в результате моделирования. По вычисленным токам затем могут быть найдены линейные параметры (многомодовые S-параметры и др.).

EMSight имеет три вида портов: порты на краю, порты перемычек и внутренние порты. Все типы портов требуют, чтобы был определен путь. EMSight допускает неограниченное число портов, и комбинация различных типов портов может использоваться внутри структуры EM. 

Наиболее часто используются порты на краю. 

Добавление портов на краю

Порт на краю всегда соединен с проводником так, что если любое направление стороны перемещается, порты движутся вместе с ними. Порт может быть добавлен только к той стороне проводника, которая является совмещенной с границей бокса. 

[image: image18.wmf]
Рис. 2.12. Порт на краю металлической формы

Чтобы прибавить порт на краю, выделите проводник  и выберите команду Draw >Add Edge Port. Переместите мышь на то ребро, где нужно поместить порт. Если это можно сделать в данном месте, сторона будет высвечена, и появится значок порта. Нажмите левой кнопкой мыши, чтобы создать порт. 

При установке портов, нумерация назначается автоматически. Номера портов увеличиваются в порядке, в котором они добавляются к структуре (рис. 2.12). Чтобы изменить номер порта, удалите порт, и добавьте его снова.

Установка опорных плоскостей

Чтобы переместить опорную плоскость, выберите порт, нажмите на опорную плоскость в конце стрелки, и перетащите ее мышью. Если стрелка не видима, то опорная плоскость совпадает с краем, а перемещение изменит опорную плоскость, что проявится в виде толстой черной линии (рис. 2.13). Заметим, что если больше, чем один порт находятся на одном крае корпуса, все опорные плоскости для портов будут изменяться одновременно.

[image: image19.wmf]
Рис. 2.13. Перемещение опорной плоскости де-герметизации 

Установка возбуждения на порту или нагрузке
Вычисленные параметры структуры не зависят от сопротивления генератора или нагрузок на портах. Однако рассчитанная плотность тока, которая используется для анимации и визуализации, зависит от возбуждения на портах и нагрузок. Чтобы установить возбуждение или нагрузку порта, нажмите два раза мышью на порте, чтобы вывести окно атрибутов порта (рис. 2.14). 
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Рис. 2.14.  Установление атрибутов порта как генератора
Чтобы подключить к порту генератор или нагрузку, нужно выбрать это порт. При возбуждении нужно установить относительный уровень мощности и фазу  возбуждения. Для описания нагрузки необходимо задать её активное и реактивное сопротивление. Способность рассчитывать токи в структуре с нагрузками на портах позволяет с помощью анимации показывать волны, перемещающиеся через структуру.
2.8. Перемычки-порты

Добавление портовых перемычек

Перемычки-порты подобны портам на краю, в которых они связаны с границей EM корпуса. Перемычки-порты используются, чтобы соединить дно корпуса и EM структуру. Эти перемычки-порты используются для создания зонда возбуждения, как показано, например, для плоской антенны на рис. 2.15.
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Рис. 2.15. Установка перемычки на углу плоскости
Перемычка-порт создается  подобно перемычке в отверстии. Чтобы добавить перемычку-порт, выбирают команду Draw > Add Via Port. Поместите курсор на проводник, где необходимо поставить порт, и нажмите левую кнопку мыши, чтобы создать перемычку. Если только что созданный порт перемычки нужно изменить,  дважды щелкните курсором на перемычке.

После отпускания курсора, нумерация портов выполнится автоматически. Номера портов увеличиваются в порядке, в котором они добавлялись к структуре. Чтобы изменить номер порта, удалите порт и вставьте его обратно.

2.9. Внутренние порты
Внутренние порты наиболее сложные из портов трех типов, и должны устанавливаться правильно. Использование внутренних портов требует хорошего понимания способов их реализации и концепции локальной (плавающей) опорной земли. S-параметры, полученные в результате моделирования, при котором используются внутренние порты - не обычные S-параметры.

Добавление внутренних портов
Чтобы добавить внутренний порт, выберите многоугольник, в котором отрицательная клемма выделена  для внутреннего порта, а затем выберите команду Draw > Add Internal Port  из меню. Переместите мышь на край многоугольника, где нужно поместить внутренний порт, и если это - разрешенная локализация, сторона будет высвечена и появится иерархическая структура порта. Нажмите левую кнопку мыши, чтобы создать порт. Появится положительная клемма внутреннего порта со знаком «+», как показано на рис. 2.16.

Пример внутреннего порта
Следующий пример поясняет использование внутренних портов. Для использования  внутренних портов должны иметься два многоугольника, смежные друг другу, как показано на рис. 2.16. Внутренний порт будет добавлен между двумя многоугольниками, которые соприкасаются друг с другом.
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Рис. 2.16. Соприкосновение двух многополюсников
Чтобы прибавить внутренний порт, выделите многоугольник, который должен иметь отрицательный вывод для внутреннего порта, затем выберите команду Draw > Add Internal Port из меню. Переместите мышь на край многоугольника, где нужно поставить порт, и если установить его разрешается, то сторона будет подсвечена, и появится иерархическая структура порта. Нажмите левую кнопку мыши, чтобы создать порт. Положительный вывод внутреннего порта появится со знаком «+» как показано на рис. 2.17.
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Рис. 2.17. Образование внутреннего порта
Важно, что на каждой стороне внутреннего порта должен появиться многоугольник. EMSight не проверят, правильно ли установлен внутренний порт, так что анализ будет всегда выполняться, но результаты могут быть ошибочными, если внутренний порт установлен неверно. 

Теперь, когда мы познакомились с основными элементами EM – структуры, рассмотрим пример создания и анализа микрополоскового фильтра

2.10. Пример создания и анализа микрополоскового фильтра

Этот пример покажет следующие операции:

- Создание новой EM структуры;

- Задание размеров корпуса;

- Задание параметров подложки;

- Черчение топологии;

- Моделирование перемычек;

- Задание портов и линий исключения;

- Моделирование, просмотр плотности тока и электрического поля.

2.10.1. Создание EM структуры

Для создание нового проекта:

1. Выберите File > New Project.
2. Выберите File > Save Project As. Появится диалог Save As.

3. Напечатайте имя проекта (например, «EM_example»), и нажмите Save.

Создание новой EM структуры:

1. Выберите Project >Add EM Structure > New EM Structure
2. Напечатайте «Interdigital Filter» и нажмите OK. В рабочем окне MWO появляется окно EM структуры (рис. 2.18).
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Рис.2.18. Создание нового проекта EM_example
Заметим, что EMSight использует прямоугольную сетку для определения структур. Иногда выгодно использовать неравномерную сетку, это даст более быстрый процесс моделирования (обычно без ухудшения точности).

2.10.2. Задание корпуса

Корпус задает материал для всех слоев в EM структуре, устанавливает граничные условия и определяет общий размер структуры и минимальные единицы сетки разбиения которые будут использоваться для спецификации материала проводников в структуре.

Чтобы задать корпус:

1. Нажмите два раза на Enclosure под Integrade Filter (под EM Structure) в дереве проекта. Появляется диалог информации о подложке (рис.2.19).

2. Выберите Metric в качестве единиц Units, и затем прокрутите стрелку и выберите mm.

3. В Box Dimensions, впечатайте «10» как  X_Dimension, напечатайте «50» в X-Division, напечатайте «10» как Y-Dimension, и «50» как Y-Division
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Рис. 2.19. Задание размеров корпуса и сетки деления по координатам

Для определения диэлектрических слоев:

4. Откройте закладку Dielectric Layers  в диалоге Substrate Information (рис. 2.20)

5. Выберите Layer 1 в разделе Dielectric Layer Parameters. Напечатайте «3» в боксе редактирования (внизу диалога) в колонке Thickness и напечатайте «1» в боксе редактирования внизу колонки «er». Оставьте значения по умолчанию в других колонках.

Замечания. Моделирование выполняется в два раза быстрее, если они без потерь. Таким образом, установите Loss Tangent=0 и используйте и идеальные проводимости всех металлизаций и перемычек в EM-структуре.

6. Выберите Layer 2 в разделе Dielectric Layer Parameters. Напечатайте «0.635» в колонке Thickness (рис.2.20) и напечатайте «9.8» в боксе редактирования внизу колонки «er». Напечатайте «0.001» в боксе редактирования Loss Tangent и «4» в блоке ниже в колонке View Scale (это расширяет 3D вид для слоя в четыре раза по сравнению с его нормальной толщиной).
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Рис. 2.20. Задание параметров диэлектрических слоев

Граничные условия для стенок корпуса всегда являются идеальными проводниками и не могут изменяться. Граничные условия для верха и дна корпуса имеют граничные условия по умолчанию, но они могут быть изменены по желанию. В данном примере эти границы остаются по умолчанию.

Для просмотра граничных условий:

1. Откройте закладку Boundaries в диалоге Substrate Information. Затем нажмите OK для окончания процедуры задания граничных условий (рис. 2.21).
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Рис. 2.21. Граничные условия

2.10.4. Добавление проводников к топологии

Вы можете использовать EM моделятор MWO для рисования физической структуры. Вы можете также импортировать структуру непосредственно из топологического редактора AWR или импортировать формы из файлов AutoCAD, DXF, GDSII или Sonnet GEO. В данном примере вы нарисуете физическую топологию используя моделятор EM.

1. Выберите Draw > Add Rect Conductor для добавления прямоугольного проводника.

2. Сдвиньте курсор в окно фильтра и нажмите клавишу Tab. Появится окно диалога ввода координат Enter Coordinates (рис. 2.22).
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Рис. 2.22. Начало рисования топологии с помощью ввода координат

3. Напечатайте «0» в качестве величин x и «2.2» как величины y, и кликните OK.

4. Нажмите клавишу Tab снова, чтобы увидеть диалог Enter Coordinates. Отметьте Re и напечатайте «2.2» как величину dx, и «0.6» как величину dy, и затем кликните OK. Прямоугольный проводник будет иметь вид как на рис. 2.23.
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Рис. 2.23. Нарисованная форма проводника фильтра

Чтобы нарисовать второй прямоугольный проводник:

5. Выберите Draw > Add Rect Conductor.
6. Сдвиньте курсор в окно фильтра и нажмите клавишу Tab. Появится окно диалога ввода координат Enter Coordinates. Впечатайте «4» как величина x  и  «2»  как величину y, и затем кликните OK.

7. Нажмите клавишу Tab снова чтобы вывести диалог Enter Coordinates. Напечатайте «1.2» как величину dx,  и  «7.2»  как величину dy, и затем кликните OK. Прямоугольный проводник будет иметь вид как на рис. 2.24.
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Рис. 2.24. Две нарисованные формы проводников фильтра

Чтобы сдвинуть второй прямоугольник к первому проводнику:

8. Кликните на втором прямоугольнике. Появятся квадратики по углам прямоугольника.

9. Передвигайте выбранный проводник, пока курсор имеет вид пересечения. Значения dx и dy будут показаны в окне (рис. 2.25).

[image: image31.png]Loper 1 Laper2





Рис. 2.25. Смещение нарисованных форм на слое Layer 2

Совет. Используйте кнопку Ruler на инструментальной линейке для измерения размеров проводника, и размеров структуры EM-топологии

10. Удерживая кнопку мыши, перетащите курсор до тех пор, пока dx и dy будут соответствовать dx:-2 и dy:-1. При отпускании кнопку мыши прямоугольник примет положение, показанное на рис. 2.26.

2.10.5. Добавление перемычек VIA
Перемычки Via это межсоединения между слоями подложки. Вы можете добавить перемычку к земляной плате  с одной стороны большого проводника к низу металлического корпуса.

1. Выберите Draw > Add Via
2. Сдвиньте курсор в окно фильтра и нажмите клавишу Tab. Появится окно диалога ввода координат Enter Coordinates. Впечатайте «2.4» как величина x  и  «1.2»  как величину y, и затем кликните OK.

3. Нажмите клавишу Tab снова чтобы увидеть диалог Enter Coordinates. Напечатайте «0.4» как величину dx, и «0.8» как величину dy, и затем кликните OK. Перемычка будет показана голубым квадратиком. 
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Рис. 2.26. Установка сечения перемычки Via
4. Выберите Edit > Copy, затем выберите Edit > Paste.

5. Сдвиньте мышь в окно EM-структуры. Появится вторая перемычка.

6. Нажмите правой кнопкой мыши для вращения одной перемычки.

7. Нажмите клавишу Tab  для вывода диалога Enter Coordinates. Деселектируйте Re  для введения абсолютных координат. Напечатайте «2.2» как величину x  и  «1.8» как величину y  и затем нажмите OK.
Просмотр трехмерного изображения

EM моделятор выводит двухмерный и трехмерный виды. Чтобы создать 3D вид:

1. Выберите View > 3D View. Появится окно, содержащее трехмерный вид конструкции.

2. Выберите Window >Tile Vertical. Окна располагаются рядом (рис.2.27).


[image: image33.png]3.635

a.635

Ve

18

1m





Рис. 2.27. Трехмерный и двухмерный вид части фильтра

Заметим, что чтобы изменить вид 3D структуры, кликните правой кнопкой мыши в 3D окне, затем выберите Zoom Window, Zoom Out, или View All.

Чтобы вращать 3D структуру, кликните на ней и удерживая кнопку мыши, вращайте.

2.10.6. Добавление портов  и плоскостей разгерметизации

EM моделятор может задать электрические порты на краю корпуса (краевые порты) и как пробники-перемычки, проходящие снизу или от поверхности дна (порты via). Для задания такого краевого порта:

1. Кликните меньший проводник в структуре EM. Заметим, что проводник должен быть расположен точно по срезу левого края (X:0; Y:2.2), перед тем, как вы добавите краевой порт к нему.

Совет: выберите View > Zoom In один или два раза для лучшего просмотра вида.

2. Выберите Draw > Add Edge Port.

3. Поместите курсор с левого края маленького проводника пока не появится квадратик, и нажмите левую кнопку мыши, для размещения порта. Маленький бокс с номером 1 (показывающий номер порта) появится с левого края проводника (рис. 2.28).
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Рис. 2.28. Установка порта с левого края микрополоскового фильтра

Для вычитания (разгерметизации) величин электрической длины из результата моделирования, референсные плоскости для порта должны быть сдвинуты от края корпуса.

Для разгерметизации 1 мм электрической длины порта 1:

4. Нажмите правой кнопкой мыши в окне EM структуры, и выберите View Area.

5. Кликните и удерживайте кнопку мыши чтобы увидеть увеличенный курсор затем протяните  курсор вокруг порта 1 и маленького проводника. 

6. Нажмите на порту 1. Четыре квадратика показывает их углы.

7. Сдвиньте мышь вокруг края порта пока курсор не покажет двойную стрелку.

8. Кликните и удерживайте клавишу мыши и увидеть dx и dy.

9. Удерживайте кнопку мыши, протащите курсор вправо пока dx не покажет 1. Отпустите кнопку мыши чтобы увидеть линию разгерметизации (рис. 2.29).
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Рис. 2.29. Смещение опорной плоскости разгерметизации порта

2.10.7. Задание частот моделирования

Для задания частоты моделирования:

1. В дереве проекта кликните правой кнопкой на Interdigital Filter под EM Structure и выберите Options. Появляется диалог Options.

2. Выберите закладку Frequency Values.
3. Деселектируйте опцию Use Project Frequency для задания установки глобальных частот поверх установки глобальных частот проекта.

4. Убедитесь что установлены GHz в Data Entry Units. Вы можете глобальные частоты моделирования (выбором Options > Project Options и выбирая закладку Frequency Values) или локально используя эти шаги. Лучше использовать установки локальных частот для EM структур, как вы обычно хотите для свипирования EM структур для нескольких частотных точек которые моделируются с линейными схемами.

5.Напечайте «1» в Start и «5» в Stop, и «1» в Step.

6.Кликните Apply и затем OK. Окно Current Range показывает диапазон и шаг частот, который вы задали (рис. 2.30).
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Рис. 2.30. Диалог установки частот моделирования

Запуск моделирования

EM моделятор очень быстро решает небольшие задачи. Чтобы найти резонансную частоту фильтра, запустим моделирования для начальной топологии.

1. Дважды нажмите раздел Information под Interdigital Filter (под EM Structures). Появляется диалог EM Solver Information (рис. 2.31) для оценки времени моделирования данной структуры.
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Рис. 2.31. Информация о необходимых ресурсах расчета EM задачи

3. Нажмите OK для закрытия этого диалога.

4. Выберите Simulate > Analyze. Индикатор процесса расчета (рис. 2.32) показывает частоты, на которых выполняется решение пошагово и процесс решения электромагнитного моделятора.

Совет: если величина требуемой памяти для решения данной задачи больше чем имеющаяся память, попробуйте переопределить задачу так, чтобы она запускалась с имеющейся памятью компьютера. 
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Рис. 2.32. Окно прогресса моделирования

2.10.8. Вывод результатов моделирования

Для определения резонансной частоты вы можете вывести вносимые потери структуры. Чтобы показать характеристику на графике:

1. Выберите Project > Add Graph. Появляется диалог Graph.

2. Выберите Rectangular как Graph Type и кликните OK.
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Рис. 2.33. Создания прямоугольного графика Graph 1

3. Кликните на окно Graph 1 для активизации его (рис. 2.33).

4. Выберите Project > Add Measurement. Появляется диалог Add Measurement.

5. Выберите S как характеристику  (рис. 2.34), выберите Interdigital Filter как Data Source Name, выберите DB в разделе Result Type, кликните ADD и затем OK.
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Рис. 2.34. Диалог вывода частотной характеристики на график

6. Выберите Simulate > Analyze. Характеристика будет показана на графике. Характеристика показывает, что резонансная частота находится вблизи 4 ГГц.

Для определения более точной характеристики резонансной частоты, вы можете изменить частотный диапазон и шаг частоты моделирования.

Изменение диапазона частот и размера шага

1. В дереве проекта, нажмите правой кнопкой мыши на Interdigital Filter под EM Structure и выберите Options. Появляется диалог Options.

2. Выберите закладку Frequency Values.

3. Напечатайте «3» как значение Start, «5» как значение Stop, значение «0.1» как Step, и затем кликните Applay. Нажмите OK.

4. Выберите Simulate > Analyze для повторного моделирования структуры. Характеристика показывается на графике рис. 2.35.
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Рис. 2.35. Частотная характеристика фильтра
2.10.9. Анимирование тока и просмотр электромагнитного поля

Просмотр анимированного тока и поля в структуре может быть полезной при исследовании его физических характеристик. Для анимирования тока на проводниках:

1. Кликните окно 3D чтобы сделать его активным.

2. Выберите Animate > Animate Play. Анимированные токи показываются на топологии в 3D виде (рис. 2.36).
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Рис. 2.36. Визуализация и анимация вида тока на поверхности проводника

3. Выберите Animate > Stop для прекращения анимации.

Чтобы показать электрическое поле на слое 2

4. Выберите Animate > E-Field Setting. Появляется диалог E-Field Computation (рис.2.37).
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Рис. 2.37. Установка для расчета электрического поля в диэлектрическом слое

5. Выберите Layer 2 и кликните OK.

6. Выберите Animate > Analyze для расчета электрического поля.

7. Выберите Animate > Play для просмотра тока и электрического поля (рис.2.38).

8. Выберите Animate > Stop для остановки анимации.
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Рис. 2.38. Просмотр напряженности поля в плоскости слоя

Для исключения расчета поля:

9. Выберите Animate > E Field Setting. Появится диалог расчета поля, в котором деселектируйте Layer 2 и кликните OK.

2.10.10. Завершение черчения топологии

Для того чтобы получить окончательную структуру фильтра, мы будем использовать несколько опций рисования.

Чтобы добавить маленький проводник в конце входного резонатора:

1. Кликните на окно Interdigital Filter чтобы сделать его активным.

2. Выберите Draw > Add Rect Conductor.
3. Сдвиньте курсор в окно Interdigital Filter и выберите View>Zoom Out. Нажмите клавишу Tab. Появляется диалог ввода координат.

4. Напечатайте «2» в окне x и «8.2» в окне y и затем нажмите OK.

5. Нажмите клавишу Tab снова и отметьте Re в диалоге ввода координат.

6. Напечайте «-0.4» как величину dx и «-0.2» как dy и затем нажмите OK. Прямоугольный проводник покажется в окне EM структуры (рис. 2.39).
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Рис. 2.39. Установка порта и сдвиг референсной плоскости

Чтобы нарисовать выходной резонатор:

7. Выберите Edit > Select All.
8. Выберите Edit > Copy, и затем выберите Edit>Paste.
9. Сдвиньте курсор и расположите копию вне входного резонатора.

10. Выберите Draw > Flip.
11. Сдвиньте курсор в середине EM окна. Кликните, а затем установите перевернутое изображение в место, противоположное входной линии (рис. 2.40).
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Рис. 2.40. Процесс создания топологии фильтра

Выровняйте перевернутую часть фильтра с выходным краем.

Для создания среднего резонатора:

12. Кликните вблизи левого угла левого резонатора и охватите резонатор. Чтобы создать больший резонатор и выбрать 2 перемычки.

13. Выберите Edit > Copy а затем выберите Edit >Paste. Затем нужно перевернуть внутренний резонатор на 180(.

Добавление порта

Для завершении EM структуры, необходимо добавить порт на выход фильтра. Чтобы добавить порт и линию разгерметизации длиной 1 мм:

1. Кликните и активизируйте правую часть фильтра.

2. Выберите Draw > Add Edge Port.
3. Разместите курсор на правом краю фильтра  и кликните на этом месте.

4. Внесите и передвиньте, аналогично первому порту, плоскость сдвига референсной плоскости, которую нужно продвинуть до координаты dx: -1.Окончательно структура имеет вид показанный на рис. 2.41.
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Рис. 2.41. Окончательная топология фильтра

Выберите Simulate > Analyze для анализа топологии.

Добавьте на график также характеристику S21 в DB. График будет иметь вид, показанный на рис. 2.42.
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Рис. 2.42. Частотная характеристика фильтра

Этим завершается пример моделирования EM структуры. Для сохранения работы выберите File > Save Project.
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