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9.3. Пример создания топологии

Прежде, чем мы будем далее обсуждать принципы топологического представления в MWO, покажем пример создания топологии из схемы. Этот процесс будет включать следующие шаги:

1. Импорт файла процессирования топологии (LPF).

2. Редактирование единиц базы данных и размера сетки.

3. Импорт библиотеки ячеек.

4. Импорт и размещение файла данных в схеме.

5. Изменение схемного символа.

6. Размещение микрополосковых линий в топологии.

7. Установка соответствия трафарета и схемного элемента.

8. Просмотр топологии.

9. Создание ячейки трафарета.

10. Привязка топологической ячейки к топологии.

11. Манипуляция элементами MTRACE в топологии.

12. Слияние форм в топологии.

13. Экспорт топологии.

Чтобы создать новый проект:

1. Выберите File > New Project.
2. Выберите File > Save Project As и дайте имя проекту (например, «Layout_example»).

9.3.1. Импорт файла процессирования слоев

Файл Layer Process File (LPF) имеет установки топологии, включая нарисованные слои, соединения между слоями, информацию о 3D представлении и топологию для электромагнитного моделирования EMSight.

Чтобы импортировать LPF:

1. Кликните закладку Layout внизу, чтобы открыть менеджер топологии;

2. Кликните правой кнопкой мыши Layer Setup, и выберите Import Process Definition. Появляется окно Open;
3. Выберите директорию …\AWR\AWR2002 (это директория по умолчанию, где инсталлирован MWO);

4. Подсветите файл MIC_English.lpf и кликните Open. Появится окно менеджера топологии, которое будет выглядеть как на рис. 9.21.
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Рис. 9.21. Окна управления топологией

9.3.2. Редактирование единиц базы данных и размера сетки по умолчанию

Единицы базы данных определяют точность топологии. Очень важно, что этот параметр не нужно изменять после того, как он установлен. Изменение единиц может привести к ошибкам округления, что вызовет проблемы в топологическом файле. Размер сетки важен еще и потому, что многие проекты должны перечерчивать сетку. Сетка должна быть больше или равна единице базы данных. Из-за того, что размер сетки кратен единице в базе данных, рекомендуется устанавливать размер сетки ровно в 10 раз крупнее, чем единицы в базе данных. Это заранее установленная минимальная сетка.

Чтобы отредактировать единицу базы данных и размер сетки:

1. Выберите Options > Layout Options (рис. 9.22)
2. Напечатайте «1» в Grid Spacing и «0.1»  в Database size, затем нажмите OK.
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Рис. 9.22. Диалог установки опций топологии

9.3.3. Импорт библиотеки ячеек GDSII
Библиотеки ячеек, используемые в MWO, обеспечивают и физическое размещение, и черчение площадок под гибридные микросхемы или навесные элементы, аналогично тому, как используются стандартные ячейки трафаретов в проектах MMIC и RFIC. MWO поддерживает формат файла GDSII как стандарт для инструментов черчения.

Чтобы импортировать библиотеку ячеек GDSII:

1. Кликните правой кнопкой мыши на Cell Library в менеджере топологии и выберите Read GDSII Library.

2. Выберите директорию …\AWR\AWR2002 (или директорию, где инсталлирован MWO).

3. Откройте поддиректорию Examples и затем дважды кликните на Quick Start.
4. Кликните файл packages.gds, а затем на Open. Импортированная библиотека ячеек показывается в менеджере топологий (рис. 9.23). 
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Рис. 9.23. Содержание импортированной библиотеки ячеек

9.3.4. Импорт файла данных

Чтобы импортировать файл данных:

1. Кликните закладку Proj.
2. Нажмите правой кнопкой мыши Data Files в дереве проекта и выберите Import Data File. Появится окно Open.

3. Выберите директорию …\AWR\AWR2002.
4. Дважды кликните на поддиректорию Examples, а затем на поддиректорию Quick Start.

5. Кликните файл N76038a.s2p и затем Open (рис. 9.24).
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Рис. 9.24. Выбор импортируемого файла данных

Чтобы поместить файл данных на схеме:

1. Нажмите правой кнопкой мыши Circuit Schematics в дереве проекта и выберите New Schematics. Появится диалог Create New Schematic.

2. Напечатайте «qs layout» и затем кликните OK.

3. Кликните закладку Elem  внизу окна, чтобы увидеть браузер элементов.

4. Найдите пункт Subcircuits и кликните на него. Внизу появятся модели подсхем.

5. Кликните на модель N76038a и, удерживая мышь, перетащите этот элемент на схему (рис. 9.25).
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Рис. 9.25. Установка подсхемы в схемное окно

Вы можете изменить количество выводов у этого элемента, поскольку ячейка должна иметь то же самое количество выводов, как и количество узлов у схемного элемента

Чтобы добавить земляной вывод к файлу транзистора:

1. Дважды кликните на элемент подсхемы в окне схемы. Появится диалог Element Option.

2. Выберите закладку Ground (рис. 9.26).
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Рис. 9.26. Установка типа вывода заземления

3. Выберите Explicit ground node и кликните OK. Появляется третий вывод у подсхемы (рис. 9.27).
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Рис. 9.27. Дополнение модели четырехполюсника третьим выводом заземления

9.3.5. Изменение символа элемента

Символ данной и любой другой подсхемы может быть изменен. Для FET удобно выбрать такой символ, чтобы видеть, какие узлы соответствуют затвору, истоку и стоку.

Для изменения символа:

1. Нажмите дважды на элемент подсхемы в схематическом окне. Появляется диалог Element Option.
2. Кликните закладку Symbol.
3. Выберите FET@system.syf в меню и затем кликните OK. Таким образом, символ подсхемы стал соответствовать рис. 9.28, что отражает его функциональное назначение.
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Рис. 9.28. Выбранный новый символ четырехполюсника

9.3.6. Помещение микрополосковых элементов в топологию

Микрополосковые элементы имеют топологические ячейки по умолчанию. Эти топологические ячейки параметризированы и топология их меняется динамически.

MWO имеет специальные элементы, называемые Icels (для адаптированных ячеек), которые не требуют никаких величин параметров от связанного с ним элемента.

Для размещения микрополоскового элемента:

1. Кликните закладку Elem, чтобы увидеть браузер.

2. Дважды кликните на Microstrip в браузере.

3. Кликните на Lines чтобы увидеть модели линии в нижней панели (рис. 9.29).
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Рис. 9.29. Дополнение схемы микрополосковой линией

4. Кликните модель MLIN и перетащите элемент на схему, соединив его с подсхемой N7068a.
5. Теперь кликните Junction в браузере Microstrip. В нижней панели появятся символы выводы (junction).
Обратим внимание, что элементы, обозначенные $ в конце имени элемента описываются (имеют свои атрибуты) характеристиками порта, к которому они присоединены. Элементы, которые имеют «X» на этом конце создаются из таблицы генерации модели EM. Таким образом, имя «MTEREX&» это микрополосковое разветвление, основанное на таблице, рассчитанной по EM модели, которая получает свою ширину от портов к которому она соединена.

6. Кликните на модель MTEE$, перетащите этот элемент на схему и присоедините его к элементу MLIN (рис. 9.30).
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Рис. 9.30. Подключение элемента разветвления микрополосковых линий MTEE
7. Кликните Lines в разделе Microstrip. Кликните модель MTRACE  в нижнем окне и перетащите этот элемент в схему, поместив его слева от MTEE$.

8. Кликните модель MLEF, перетащите ее в схему, сделав поворот и присоедините к узлу 3 элемента MTEE$.

9. Дважды кликните на элемент MTRACE на схеме чтобы открыть окно Element Options.

10. Отредактируйте параметры элемента MTRACE и согласуйте их как на рис. 9.31.
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Рис. 9.31. Дополнение схемы усилителя шлейфом и линией

11. Повторите шаг 9 для редактирования их параметров элементов MLIN и MLEF.

12. Кликните Substrates в браузере элементов. Модели подложек появятся в нижней панели.

13. Кликните на модель MSUB и перетащите ее на схему.

14. Дважды кликните на элемент MSUB и установите параметры подложки, как на рис. 9.32. Нажмите OK.
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Рис. 9.32. Включение данных о подложке в схему транзисторного СВЧ усилителя

15. Кликните кнопку Port и перенесите его на схему, поместив слева элемента MTRACE. Аналогично, установите второй порт к стоку транзистора (рис. 9.33). А к истоку транзистора присоедините землю.
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Рис. 9.33. Подключение входного и выходного портов

9.3.7. Установка соответствия топологии ячейки и элемента схемы

 Топологическая ячейка, которая представляет топологию, может быть связана со схемным элементом. Для этого:

1. Дважды нажмите элемент подсхемы N76038a в схематическом окне,  для вывода диалога Element Option.

2. Откройте закладку Layout (рис. 9.34).
3. Выберите Alpha_212_3 в Compatible cells и затем кликните OK.
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Рис. 9.34. Выбор символа ячейки

9.3.8. Просмотр топологии

Схема и топология – это разное представление одной и той же базы данных. Любые редактирования параметров на схеме немедленно отражаются на топологии и наоборот.

Чтобы увидеть топологию:

1. Кликните на схематическое окно и сделайте его активным

2. Выберите Schematic > View Layout. Топология появится в топологическом окне.

3. Выберите Edit > Snap Together, чтобы соединить все фаски элементов топологических ячеек вместе (рис. 9.35). Для вывода топологии можно также нажать кнопку View Layout на инструментальной панели.
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Рис. 9.35. Создание и слияние топологии

9.3.10. Привязка (фиксация) топологической ячейки

Топологические ячейки имеют различные свойства, которые определяют связи каждой ячейки в общей топологии. Одно из важнейших свойств - это фиксация положения. Оно сохраняет положение ячейки так, что она не будет изменена никакими операциями сдвига. Это свойство обычно используется для задания опорных точек топологии.

Чтобы зафиксировать топологическую ячейку:

1. Выберите соответствующую ячейку Alpha_212_3. Нажмите правой кнопкой мыши и выберите Shape Properties для вывода диалога свойств ячейки (рис. 9.36). 
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Рис. 9.36. Диалог свойств ячейки

2. Кликните закладку Layout выберите Use for anchor  и затем кликните OK. Топологическая ячейка получит теперь следующий символ якоря, как показано на рис. 9.37. 
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Рис. 9.37. Окончательная фиксация положения транзистора

Создание топологической ячейки

Чтобы создать топологическую ячейку:

1. Кликните кнопку Set Grid Snap Multiple на инструментальной панели и установите его на 10x. 
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Рис. 9. 38.  Команда установки частоты сетки

2. Откройте закладку Layout для активизации менеджера топологии.

3. Правой кнопкой нажмите на Packages и выберите New Layout Cell (рис. 9.39). Появится диалог Create New Layout Cell. 
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Рис. 9.39. Команда создания новой топологической ячейки

4. Назовите ячейку «chip cap» и кликните OK.
5. Кликните прямоугольную кнопку «Copper» в левом столбике, чтобы активизировать слой меди, как показано на нижнем рисунке (не нажимайте лампочку (рис. 9.40), так как это задает только высвечивание слоя для показа). 
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Рис. 9.40. Выбор слоя для создания и редактирования

6. Выберите Layout > Rectangle.

7. Сдвиньте курсор в окно рисования и затем нажмите на клавишу Tab. Появится диалог ввода координат.

8. Напечатайте «0» и «10» соответственно в поля x и y и кликните OK.

9. Нажмите снова клавишу Tab для ввода координат и введите «10» и «-10» в поля dx и dy, соответственно. В результате будет нарисована форма, рис. 9.41.
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Рис. 9.41. Создание формы на слое

10. Кликните бокс Footprint (площадки) в левой колонке нижней панели менеджера топологии чтобы активизировать слой подложки как активный слой.

11. Кликните окно рисования чтобы сделать его активным.

12. Выберите Layout > Rectangle.
13. Сместите курсор с окна рисования, затем нажмите на клавишу Tab. Введите координаты «10» и «10» соответственно в поле x  и y и нажмите OK.

14. Нажмите Tab снова и введите «20» и «-10» в поля dx и dy соответственно. Топология будет соответствовать рис. 9.42.
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Рис. 9.42. Добавление формы на другом слое

15. Кликните снова на квадратик copper в окне рисования и нажмите Ctrl+C, а затем Ctrl+V чтобы внести в его буфер. Сдвиньте положение курсора и скопируйте квадратик меди справа прямоугольника, а затем кликните на него, чтобы разместить точно в нужное место (рис. 9.43). 
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Рис. 9.43. Создание форм ячейки на двух слоях

Добавление портов в топологической ячейке

Порты в топологической ячейке задаются фасками (стыковочными гранями), определяемыми на топологии для соединения с другими ячейками. Стрелки ориентации портов задают направление соединения со смежной ячейкой.

Чтобы добавить порты к топологической ячейке:

1. Выберите Layout > Cell Port.

2. Сдвиньте курсор в окно рисования, нажмите и удерживайте клавишу Ctrl пока сдвигаете курсор сверху нижнего левой вершины квадрата символа до появления символа квадратика (рис. 9.44). Не отпускайте клавишу Ctrl. 
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Рис. 9.44. Установление координаты стыковочной грани

3. Пока клавиша Ctrl нажата, кликните и удерживайте кнопку мыши, пока вы сдвигаете курсор к верхней вершине до появления другого квадратика (рис. 9.45). Отпустите клавишу мыши, а затем клавишу Ctrl. 
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Рис. 9.45. Создание порта на стыковочной грани

4. Повторите шаги c 1 до 3, помещая порт на противоположной стороне (рис. 9.46), но начинайте рисовать на верхней вершине и ведите курсор вниз.  
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Рис. 9.46. Создание второго порта топологической ячейки

5. Кликните на X сверху справа окна chip cap.

Редактирование схемы и связь топологии и схемы
навесного конденсатора

Чтобы отредактировать схему и связанного с ней топологию навесного конденсатора:

1. Кликните на PORT 1 в окне схемы.

2. Нажмите и удерживайте клавишу Ctrl, и удерживайте кнопку мыши, пока вы перетаскиваете порт от элемента MTRACE как показано на рис. 9.47. [image: image27.wmf]MLIN
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Рис. 9.47. Удаление конденсатора из схемы усилителя

3. Кликните закладку Elem, дважды кликните на Lumped Element, затем кликните на Capacitor, чтобы увидеть модели емкости в нижней панели.

4. Кликните модель CAP и удерживая кнопку мыши, перетащите элемент на схему, отпустите кнопку мыши, поместив элемент между PORT 1 и элементом MTRACE.

5. Дважды нажмите на элемент CAP C1 в окне схемы. Появляется диалог Element Options (рис. 9.48).

6. Кликните закладку Layout. 
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Рис. 9.48. Установка нового символа элементу C1

7. Выберите chip cap в Compatible cells и кликните OK.
8. Выберите Schematic > View Layout. Новая обновленная топология включила ячейку навесного конденсатора (рис. 9.49).
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Рис. 9.49. Новая топология усилителя, включающая конденсатор

9.3.11. Использование элемента MTRACE в трассировке топологии

MTRACE – это специальный элемент, который позволяет изменять топологию при прочерчивании пути в виде микрополосковой линии.

Для использования элемента MTRACE:

1. Дважды кликните на элементе MTRACE в Layout View для активизации синих ромбиков, как показано на следующем рисунке.

2. Сдвигайте курсор мыши правого ромбика, пока не появится символ двойной стрелки. Дважды нажмите для активизации инструмента трассировки (рис. 9.50).

3. Сдвиньте инструмент трассировки к желаемой точке и кликните в этой точке (нажатие правой кнопки мыши удалит последнюю точку, а нажатие Esc снимет активность команды).

4. Продолжайте устанавливать точки трассы, нажимая каждый раз в новой точке и дважды щелкните при окончании трассировки (рис. 9.51).
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Рис. 9.50. Активизация микрополосковой линии
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Рис. 9.51. Изменение топологии входной микрополосковой линии

Отметим, что элемент MLIN – это прямой отрезок линии, и вы можете изменять его ширину и длину. Вы можете редактировать элементы MTRACE в топологии для создания скачков ширины, срезанных поворотов и скошенных углов.

9.3.12. Функции слияния для топологических ячеек

Функции слияния связывают стыковочные грани топологических ячеек в различных конфигурациях. MWO 2002 имеет новые опции слияния, которые можно установить из диалога Layout Option. Для спецификации опций слияния топологий:

1. Выберите Option > Layout Options. Появляется окно Layout Options (рис. 9.52).

2. Выберите Manual snap selected objects only в разделе Layout Cell Snap Options. Кликните OK. Это будет режим привязки к сетке только выбранного объекта.
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Рис. 9.52. Установка опций топологии для интерактивного объединения форм

Чтобы отодвинуть топологические ячейки одна от другой так, чтобы были видны изменения:

3. Кликните на топологическую ячейку MLEF и удерживая кнопку мыши, перетащите её в новое положение. Кликните при размещении на новом месте.

4. Повторите шаг 3 с элементов MTRACE и ячейкой навесного конденсатора. Положение топологической ячейки как на рис. 9.53.

Красные нити показывают, что фаски топологических ячеек не сливаются вместе. 
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Рис. 9.53. Перенесение элементов C1 и шлейфа в другие положения

5. Удерживайте клавишу Ctrl, выберите топологические ячейки MLEF, MTRACE и MTEE$ в топологическом окне (рис. 9.54). 
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Рис. 9.54. Активизация элементов для слияния

6. Кликните кнопку Snap Together на инструментальной линейке. Отметим, что топология навесного конденсатора и топологическая ячейка MLIN не слиты вместе.

Чтобы слить все фаски вместе:

7. Нажмите Ctrl+A на клавиатуре и выберите все топологические ячейки. Кликните кнопку Snap Together на инструментальной линейке. Топология будет иметь вид как на рис. 9.55.
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Рис. 9.55. Новая слитая топология усилителя

Функция «snap to fit» оканчивает трассировку топологических ячеек MTRACE для спецификации смежных топологических ячеек. 

9.3.13. Экспорт топологии

Чтобы экспортировать топологию:

1. Выберите Options > Drawing Layers для задания слоев для экспорта в файл. Появляется диалог Layer Setup.

2. Кликните закладку Export Mapping.
3. Кликните закладку DXF внизу диалога, снимите выделение всех нарисованных слоев. кроме слоя меди в Write Layers и кликните OK.

4. Выберите Layer > Export Layout. Появляется диалог Save As.

5. Выберите формат DXF (*.dxf) в разделе Save as type.

6. Впечатайте «myfile» как File Name и кликните Save для экспорта файла со слоем меди как файл DXF.

На этом завершается рассмотрение примера создания и обработки топологии. Теперь вы можете сохранить работу выбором File > Save Project.
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