Глава 2. 


Создание графической модели
СВЧ устройства

     Прежде, чем вы перейдете к черчению геометрической модели, рекомендуем выполнить следующее:

• Подготовьте изображение структуры на бумаге, с размерами.

• Продумайте структуру в ее составных частях. Сделайте наброски частей.

• Если структура сложная, сделайте список частей, которые составляют всю структуру.

      Помните, что для моделирования поля важно задать внутреннее пространство структуры,  где распространяются электромагнитные волны, а не только ее поверхность.

    Для примера, начертим и подготовим к решению следующие модели:

• коаксиальное Т- образное разветвление;

• микрополосковый фильтр нижних частот;

• рупорную антенну.

2.1. Черчение коаксиального Т-образного разветвления
      В качестве первого примера возьмем коаксиальное Т- образное разветвление (рис. 2-1). В силу особенностей алгоритма решения электромагнитной задачи, HFSS выполняет разбиение на элементарные ячейки некоторого объема (области пространства). Поэтому программа в результате черчения должна получить не набор поверхностей, а именно замкнутый объем. В случае Т-образного разветвления это часть пространства, заключенная между внешними и внутренними проводниками, а также между плоскостями, ограничивающими коаксиальные линии по длине. Отсюда становится ясно, что простого черчения цилиндрических проводников недостаточно. Программе нужно еще указать, какая часть пространства должна использоваться при анализе. Для этого существует процедура вычитания, которая исключает часть пространства из анализа. Например, вычитая из внешнего цилиндра внутренний, мы, тем самым, удаляем из анализа часть пространства, ограниченную внутренним проводником. 

      Другими словами, область, представляющая интерес для анализа - область между поверхностями внешнего и внутреннего цилиндров (рис. 2-1).

Это тот случай, когда полые цилиндры по существу “высверливаются” коман-дой вычитания и область, представляющая интерес, определена как воздух. Полые цилиндры становятся внутренней границей области,  и заполнены иде-альным электрическим проводником (металлом) по умолчанию.
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Рис. 2-1. Область моделирования в коаксиальном Т-образном разветвлении.

Процесс черчения коаксиального Т-образного разветвления состоит из следующих шагов: 

• Рисуем внутренний и внешний цилиндры для коаксиальной линии располо-женной вдоль oz оси.

• Рисуем внутренний и внешний цилиндры для коаксиальной линии располо-женной вдоль  oy оси.

• Объединяем внешние цилиндры по осям oz и oy, а затем объединяем внут-ренние цилиндры.

• Вычитаем внутренний, объединенный объект, из внешнего объединенного объекта.

• Разрезаем коаксиальное Т-образное соединение пополам по оси y-z.

Итак, начнем пошаговое изучение программы HFSS. Очень важно пройти эти примеры от начала до конца.

1. Запустите программу. Появляется диалоговое окно менеджера проектов.

2. В списке Projects, нажмите New. Появляется диалоговое окно New Project.

3.  Напечатайте имя coaxtee в поле New Project.

4. Нажмите клавишу Return или кнопку  OK.

Установки проекта

     После нажатия OK появляется окно Project Preferences для выбора установок рабочего стола, в котором мы будем чертить наши формы. Нам нужно устано-вить размеры сетки и единицы.

1. Для данного примера используйте параметры, которые показаны на рис. 2-2.
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Рис. 2-2. Установки проекта для коаксиального Т-разветвления

2. Нажмите OK.

Черчение коаксиальной линии расположенной вдоль оси OZ
Чтобы начертить коаксиальную линию, идущую по Z-оси, нарисуем внутренний и внешние цилиндры в X-Y плоскости. 

- Черчение внешнего цилиндра
1. Нажмите на  Model > Draw, после чего экран будет готов для рисования.

2. Нажмите на 3D Objects > Cylinder.
3. Поместите курсор в начало X-Y координат и нажмите левую кнопку мыши, чтобы задать центр цилиндра. 

4. Переместите курсор из центральной точки, которую Вы задали. Обратите внимание, что круг на экране то сокращается, то растет, когда Вы перемещаете мышь.

5. Нажмите левую кнопку мыши, чтобы задать внешний край для цилиндра.

Не волнуйтесь относительно размера круга. Вы точно выставите его в диало-говом окне, которое появится.

6. Обратитесь к диалоговому окну на рис. 2-3 и установите начало координат, размеры и другие данные для вашего цилиндра.


[image: image3.png]Origin Dimensions

Pick Paint

€ World Coordinates

@ Local Coordinates

Object Attibutes

Object Name Object Color ™
bookt___ = mEm
Material

a I™ Use in Simulation
Hetal

=





Рис. 2-3. Цилиндрический шаблон для внешнего цилиндра Z-оси

      В  HFSS круг аппроксимируется многоугольником, имеющим N одинаковых углов и соответственно N идентичных сторон. Каждая его сторона формирует сегмент окружности. Каждый такой сегмент характеризуется углом сегмента, который равен углу между радиальными линиями, проведенными из центра окружности к вершинам сегмента. Этот угол равен 360(/N.

Поле для Segment Angle (угол сегмента) используется, чтобы задать число сторон, которое имеет круг. Чем больше угол, тем более крупный и менее совершенный круг. Чем меньше угол, тем большее количество сторон в круге и более совершенный и ровный круг. Поскольку коаксиальное Т-образное соединение - простая структура, которая не будет требовать много компью-терных ресурсов для решения, Вы можете использовать здесь угол сегмента в 15(.

Обратим внимание на опцию для использования глобальных (World) или ло-кальных (Local) координат (рис. 2-3). Система координат World  - это фик-сированная декартовая система координат, которая использует три оси: X, Y, и Z , чтобы описать точку в трехмерном пространстве.

   Локальная система координат – это выбранная в момент черчения система XoZ, YoZ или любая другая заранее описанная плоскость, которая может занимать в пространстве любое положение (рис. 2-4). Тогда вновь вводимый примитив будет наноситься в заданную локальную систему координат. Чтобы использовать локальную систему координат, нажмите кнопку Local (UV плоскость). Эту локальную систему координат можно смещать и вращать, отно-сительно системы глобальных координат в диалоге Plane Define в меню Define (рис. 2-4), а затем установить эту новую плоскость командой Plane Set в этом же меню (рис. 2.5).
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Рис.  2-4. Создание новых локальной системы координат UC_Axis0
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Рис. 2-5. Установление в поле черчения новой локальной системы координат UC_Axis0

     В диалоговом окне Object Attributes (атрибуты объекта) на рис. 2-3 вы видите поле Object Name (имя объекта). Хотя это поле заполнено именем по умолча-нию, полезно напечатать наглядное имя. На рис. 2-3 имя объекта  xycylout указывает, что это - внешняя часть коаксиала, который находится в X-Y плоскости.

Вы можете нажать на любой цвет, чтобы изменить цвет цилиндра.

     Материалы объектов определяют,  выбирая его в разделе Material (рис. 2-3) и отмечая поле Use in Simulation (использование в моделировании). Так как этот объект еще не представляет законченный коаксиал, не волнуйтесь относительно использования его в моделировании или определении материалов, поскольку это можно будет изменить.

7. Когда диалоговое окно заполнено, нажмите OK. Цилиндр создан на X-Y плоскости, как на рис. 2-6.
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Рис. 2-6. Внешний цилиндр по Z-оси, начерченный в локальной плоскости UV или XY 

     Большинство 2D и 3D объектов, даже если они создаются на промежуточном шаге и не нужны для окончательного устройства, сохраняются с проектом, если Вы их не стираете. Их удобно сохранять только для целей редактирования. Объект может быть установлен как невидимый или не моделируемый, коман-дами Edit > Visible, и Edit > Simulation.

Например в коаксиальном Т-разветвлении цилиндры, которые используются, чтобы создать окончательную конструкцию, сохранены со структурой как параметрические объекты.

Чтобы модифицировать объекты:

1. Из меню выберите Edit > Object Parameters. Появляется окно Parametric Object Information (рис. 2-7).
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Рис. 2-7. Окно выбора объектов для редактирования

2. Сделайте двойной щелчок на объекте, который Вы желаете редактировать.

Появляется шаблон объекта.
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Рис. 2-8. Окно параметров цилиндра

3.  Отредактируйте любой из параметров, который Вы хотите изменить и нажмите OK.

Чертеж изменяется автоматически, отражая эти изменения.

Черчение внутреннего цилиндра

     Чтобы начертить внутренний цилиндр, выполните те же самые шаги, какие Вы делали, когда чертили внешний цилиндр, но введите новые размеры для цилиндра, как показано на рис. 2-9.

Также используйте имя xycylin для описания внутреннего цилиндра, который лежит на X-Y плоскости.
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Рис. 2-9. Задание размеров  внутреннего цилиндра по Z-оси. 

   В результате  внутренний и внешний цилиндры должны выглядеть,  как на рис. 2-10.
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Рис. 2-10. Форма внутреннего и внешнего цилиндра по оси Z

Черчение коаксиала по оси Y 

    Чтобы начертить коаксиал, идущий вдоль оси Y, нарисуем внешний и внутренний цилиндры в плоскости Z -X. Сначала мы должны установить плоскость для рисования цилиндров, которые стоят перпендикулярно уже нарисованным. Для этого переустановим локальную систему координат так, чтобы начертить примитивы цилиндров.

Установка Z -X  плоскости

1. Выберите команду меню Define > Plane Set. Отображается список плоскостей.

2. Выберите ZX_plane (XZ плоскость) и нажмите OK. В плоскости XoZ отобра-жается сетка (рис. 2-13), указывая плоскость, где Вы будете чертить.

Черчение внешнего и внутреннего цилиндров в Z-X  плоскости
Чтобы начертить внешний и внутренний цилиндры в Z-X  плоскости, следуйте тем же самым командам, что и черчение коаксиала вдоль z-оси.

Выберите 3D Objects > Cylinder, и определите центр и внешний край для ци-линдра. Теперь используйте размеры на рис. 2-11.


[image: image11.png]€ World Coordinates

@ Local Coordinates

Object Attibutes

Object Name Object Color ™
bookt | = mEm
Material

air 7 Use in Simulation
Hetal

=





Рис. 2-11. Задание размеров внешнего цилиндра, расположенного вдоль оси  Y
Для внутреннего цилиндра выберите 3D Objects > Cylinder и определите центр (Origin) и размеры внутреннего цилиндра. Для этого используйте размеры на рис. 2.-12.
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Рис. 2-12. Шаблон цилиндра для внутреннего цилиндра по оси Y.

Чертеж должен принять вид, показанный на рис. 2-13.
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Рис. 2-13. Все цилиндры, которые составляют коаксиальное Т- образное соединение

Объединение цилиндров 
для создания Т-образного соединения

Чтобы создать соединение между  коаксиальными трубами, расположенными по оси Z и  по оси Y, используют команду 3D Objects > Unite .

1. Нажмите на 3D Objects > Unite  (объединение  3D объектов). Отображается диалоговое окно Object Unite.

2. Из списка 3D объектов, нажмите на xycylout и xzcylout.

3. В поле для названия объекта впечатайте более подробное имя, типа coaxout.

4.  Щелкните OK.
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Рис.  2-14. Объединение внешних цилиндров и создание объединенного объекта coaxout
     Объединенные внешние цилиндры отображаются в окне проекта, как на рис. 
2-15.
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Рис. 2-15. Объединенные внешние цилиндры

5. Снова выберите 3d Objects > Unite.

6. На сей раз нажмите на объекты xycylin и xzcylin, и назовите полученный объект coaxin.
7. Щелкните OK.

Внутренние цилиндры объединяются, чтобы сформировать внутреннюю часть коаксиального  Т-образного разветвления.

Вычитание внутреннего Т-образного разветвления 
из внешнего Т-образного разветвления

    Как обсуждается в начале этой главы и показано на рис. 2-1, область моделиро-вания, представляющая интерес — та, где существуют электромагнитные поля, то есть область между внутренним и внешним цилиндрами.

Поэтому используется команда вычитания, чтобы вычесть внутренние цилин-дры из внешних цилиндров. Представить это можно так, как будто Вы высвер-ливаете внутренний цилиндр, чтобы представить внутреннюю идеальную про-водящую границу.

Чтобы вычесть внутренний цилиндр:

1. Нажмите на 3D Objects > Subtract (вычитание 3D объектов). Появляется диалоговое окно Object Subtract.

2. В списке  Core Objects 3D нажмите на coaxout.

3. В списке вычитаемого Subtract Objects нажмите на coaxin.

4. В поле для имени нового объекта Object name напечатайте имя coaxtee.

5. Оставьте в поле Use in Simulation  отметку о моделировании, потому что далее Вы будете моделировать этот объект.

6. В поле Materials выберите air (воздух).

7. Нажмите OK.
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Рис. 2-16. Процесс вычитания одного объекта  coaxin из внешнего объекта coaxout и получение coaxtee  
    После вычитания внутреннего цилиндра из  внешнего цилиндра объекты не изменятся на экране, однако действие выполнено, и  внутренний металлический проводник каоксиального Т-образного соединения «высверлился».
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Рис.  2-17. Окончательно созданное T- образное сочленение в интерфейсе программы HFSS
Разрезание на части коаксиального 
Т-образного соединения

Если в структуре имеется электрическая или магнитная симметрия, вы можете разрезать ее вдоль плоскости симметрии, и искать поле для половины структуры, которая остается после разрезания. Или вы можете просто чертить половину, четверть или даже меньшую часть структуры и затем моделировать полную структуру.

Решение только для части структуры экономит время,  дисковое прост-ранство и память. Однако если структура имеет геометрическую симметрию, то это еще не значит, что она обязательно имеет электрическую или магнитную симметрию. Для наличия такой симметрии необходима симметрия возбуждаю-щего поля или токов.

Коаксиальное Т-образное сочленение имеет симметрию, соответствующее иде-альной магнитной плоскости, расположенной в плоскости YоZ. Поэтому мы можем для ускорения расчета разрезать нашу структуру пополам магнитной стенкой, расположенной в плоскости YoZ. Задача решится быстрее, и потребу-ется меньшее количество памяти прямого доступа.

Для рассечения коаксиального Т-образного соединения:

1. Нажмите на Edit > Slice. Диалоговое окно Object Slice отображается.

2. Из списка Objects 3D нажмите на coaxtee.

3. Из списка Plane выберите YZ plane.

4. Нажмите OK.
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Рис.  2-18. Диалог разрезания объекта coaxtee  плоскостью YZ_plane
Коаксиальное Т-образное соединение разрезается пополам по Y-Z  оси, остав-ляя половину, которая сохраняется в положительном направлении X, как на рис. 2-19 (Keep «positive normal» objects).
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Рис. 2-19. Разрезанное на части коаксиальное Т-образное соединение 

Сохранение коаксиального Т-образного соединения

Нажмите на File > Save, чтобы сохранить вашу работу черчения.

Когда Вы нажимаете File > Return to Main, чтобы возвратиться к главному экрану, отображается диалоговое окно Object Simulation, как на рис. 2-20. Список 3D показывает объекты (coaxin и  coaxtee), которые являются видимы-ми (V  отображено слева от имени объекта), и объекты, которые выбраны, что-бы использовать на моделировании (S отображено слева от имени объекта).
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Рис. 2-20. Диалоговое окно моделирования объектов

Все объекты, которые Вы создали,  сохранены с проектом, если Вы явно не стираете их, даже при том, что они не видны в этом диалоговом окне. 

Если Вы снова нуждаетесь в них, чтобы создать другие объекты, Вы можете редактировать их параметры, и чертеж модифицируется автоматически.  

Для данного примера имя, разрезанного на части coaxtee появляется в диалого-вом окне, потому что это окончательный объект, который Вы создали. Материалы, порты, и границы определяются только для тех объектов,  которые будут использоваться в моделировании.

Как Вы видите, имя  coaxtee сопровождается отметкой (V). Убедитесь, что coaxtee также используется в моделировании (S), и нажмите OK, чтобы сохра-нить проект и возвратиться к основному экрану.

Итак, Вы полностью выполнили чертеж коаксиального Т-образного соедине-ния. 

2.2. Черчение микрополоскового фильтра 
нижних частот
Для этого примера рисуется только половина структуры, потому что фильтр на микрополосковой линии имеет магнитную симметрию. 

Сначала рисуется два параллелепипеда (в англоязычной литературе часто используется термин бокс – коробка, вместо математического термина  «параллелепипед», мы также будем использовать и его), один поверх другого, представляющие подложку и воздух (рис. 2-21). Далее  рисуется двумерная микрополос-ковая линия на верхнем слое подложки.
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Рис. 2-21. Размеры НЧ фильтра на микрополосковой линии

Используем следующую последовательность шагов для черчения микропо-лоскового фильтра:

• Установка проекта.

• Черчение одной половины бокса подложки.

• Черчение одной половины бокса воздушного корпуса.

• Черчение половины двумерной микрополосковой линии.

Установки проекта

1. Запустите программу HFSS. Появляется менеджер проектов.

2. В списке Projects нажмите New. Появляется диалоговое окно New Project.

3. Впечатайте имя lpfilter в поле New Project.

4.  Нажмите OK.

Каталог, названный lpfilter, создан в папке проектов по умолчанию. Это каталог, где будут сохранены все файлы, связаные с этим проектом. Вы можете созда-вать или изменять проектные папки, если Вы не желаете использовать задан-ную по умолчанию папку.

Диалоговое окно Project Preferences появляется, чтобы установить единицы и параметры сетки для проекта.

5.  Для этого примера используйте параметры настройки, которые показываются на рис. 2-22.
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Рис. 2-22. Установки проекта НЧ фильтра  на микрополосковой линии

6. Нажмите OK.

Черчение бокса подложки

Чтобы чертить диэлектрик для НЧ фильтра на микрополосковой линии, обратитесь к рис. 2-13 и выполните следующие шаги:

1. Из главного экрана нажмите на Model > Draw. Появляется экран Draw.

2. Нажмите на 3D Objects > Box.

3. Поместите курсор около X-Y начала координат и нажмите левую кнопку мыши, чтобы определить угол корпуса.

Переместите курсор в противоположный угол для бокса. Обратите внимание, что прямоугольник рисуется на экране и что он сокращается и изменяется, когда Вы перемещаете мышь.

4. Нажмите левую кнопку, чтобы задать противоположный угол для корпуса.

Не волнуйтесь относительно размеров бокса. Вы уточните их в шаблоне бокса, который показан на рис. 2-23. 

Обратитесь к диалоговому окну на рис. 2-23 и используйте данные из рисунка для вашего бокса. Заметим, что в диалоге объект назван dielectric.
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Рис. 2-23. Шаблон параллелепипеда для диэлектрика

5. Когда шаблон бокса заполнен, нажмите OK.

Диэлектрик рисуется, как на рис. 2-24.


[image: image24.png]



Рис. 2-24. Половина диэлектрика

Черчение воздушной коробки

Чтобы начертить воздушную коробку, которая охватывает фильтр на микрополосковой линии, обратимся к рис. 2-21 и выполним следующие шаги:

1. Из экрана рисования нажмите на 3D Objects > Box.

2. Переместите курсор в X-Y начало координат и нажмите левую кнопку мыши, чтобы определить угол поля.

3. Переместите курсор в противоположный угол для поля.

Обратите внимание, что прямоугольник рисуется на экране и что он привязывается к противоположному углу диэлектрика.

4. Нажмите левую кнопку, чтобы определить противоположный угол для бокса. Шаблон бокса отображается. 

5. Обратитесь к диалоговому окну на рис. 2-25 и используйте отображенные размеры и другие данные для вашего корпуса. Заметим, что на рис. 2-25 объект назван airbox.
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Рис. 2-25. Шаблон корпуса для Airbox

6.  Когда шаблон поля заполнен, нажмите OK.

Airbox рисуется, как показано на рисунке 2-26.




Рис. 2-26. Половина диэлектрика и воздушной коробки Airbox

И воздушная коробка, и диэлектрик являются редактируемыми объектами, так что вы можете редактировать их в любое время командой Edit > Object Parameters.
Определение двумерной плоскости для микрополосковой линии

Прежде чем вы начинаете черчение микрополосковой линии, определите плоскость, где она будет размещаться. Вы хотите, чтобы  двумерный объект (металлическая форма) был сверху диэлектрического слоя. Поэтому определите плоскость, которая находится на 25 миллидюймов (милс)  выше плоскости XoY, т.е. ее координата Z=25 милс.

1. Щелкните на Define > Plane Define. Появляется диалог, показанный на рис. 2-27. Нажмите кнопку Pick Plane в этом окне. Курсор мыши становится квадратиком. Квадратик отображается в перекрестиях, и в текстовой области появляется подсказка для введения начала координат (Origin).

2. Поместите курсор на одном узле сверху диэлектрика и нажмите левую кнопку мыши. Появляется сообщение «“Pick X axis point or type coordinates, or type ‘r’ for relative:” (Нажмите точку на оси Х или напечатайте координаты, или напечатайте ' r ' для относительного числа:)».

3. Переместите курсор в другой угол вверху диэлектрика и нажмите левую кнопку мыши. Появляется сообщение “Pick Y axis point or type coordinates, or type ‘r’ for relative:”

4.  Переместите курсор в третий угол верхнего диэлектрика, и нажмите левую кнопку мыши. Снова появляется диалоговое окно Define Plane (рис. 2-27).

5.  Дайте плоскости название mstrip_plane, как на рис. 2-27.

6. Щелкните Apply и затем нажмите Done.




Рис. 2-27. Диалоговое окно определения плоскостей  

Плоскость mstrip_plane добавляется к списку плоскостей и становится заданной по умолчанию плоскостью, на которой рисуются объекты. Чтобы чертить на ней форму микрополосковой структуры, необходимо ее сделать активной. Для этого в меню Define выберем команду Plane Set. Появляется диалог Set Plane (рис. 2-28), в котором нужно активизировать линию mstrip_plane.
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Рис. 2-28. Диалог выбора активной плоскости

Черчение микрополосковой линии

Чтобы начертить микрополосковую линию, используйте команду Polyline и  текстовую область внизу экрана, чтобы ввести числа, соответствующие относительным смещениям для каждой точки, которую Вы желаете ввести.

1. Из экрана черчения нажмите на 2D Objects > Polyline.

Чтобы начертить ломаную линию, необходимо ввести точки, между которыми чертятся прямые линии. Введите набор абсолютных координат для первой точки в системе координат U-V. Затем, используйте относительное смещение так, чтобы каждая следующая точка, которую Вы вводите,  получала координаты смещения относительно предыдущей.

Подсказка “Pick first point or type coordinates” (укажите первую точку или напечатайте координаты) показывается в текстовой области внизу экрана.

2. Впечатайте значения 0, 185 и нажмите Enter.

Первая точка помещается на краю диэлектрика, и область текста  запрашивает Вас выбирать или вводить другую точку или нажать r для введения  относительного смещения.

Заметим, что Вы можете отменять любую точку, которую Вы добавили,  щелкая правую кнопку мыши. Вы можете отменить  ввод ломаной линии полностью, нажимая клавишу Escape.

3. Напечатайте r.

Этот текст показывает  сообщение “Pick next point or type relative offset, or type ‘a’ for absolute.” (укажите следующую точку или напечатайте относительное смещение или напечатайте 'а ' для абсолютного смещения.)

4. Напечатайте 0, -12.5 и нажмите клавишу Enter.

Первая линия микрополосковой формы рисуется на экране.

6.  Напечатайте остающиеся точки, нажимая Enter после ввода каждой строки:

	70
	0

	0
	-60

	45
	0

	0
	65

	65
	0

	0
	-125

	25
	0

	0
	125

	65
	0

	0
	-65

	45
	0

	0
	60

	70
	0

	0
	12.5

	-385
	0


С вводом последней точки сегменты линии сливаются, формируя двумерный объект, и появляется диалоговое окно 2D Object Completion.

6. В поле для названия объекта напечатайте microstrip. Нажмите OK.

Набор сегментов линии должен быть похож на рис. 2-29.
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Рис. 2-29. Окончательно начерченная половина микрополоскового фильтра

Нажмите на File > Save, чтобы сохранить работу черчения. 

Когда Вы нажимаете File > Return to Main, чтобы возвратиться к основному экрану, отображается диалоговое окно Object Simulation, в которому установите, что объектом моделирования является микрополосковая линия microstrip. 

2.3. Черчение рупорной антенны

Рупор - простая антенная структура. Чтобы начертить её, используется  полезная команда черчения, команда подключения Connect, для создания трехмерных объектов из двумерных объектов, которые составляют верхнюю и нижнюю границу рупора. Обратимся к рис. 2-30, на котором изображена рупорная антенна с ее размерами в дюймах.
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Рис. 2-30. Размеры рупорной антенны

Процесс черчения рупорной антенны состоит из следующих шагов:

• Черчение прямоугольника, который представляет собой  основание рупора, совпадающее с сечение выходного волновода.

• Черчение двумерного прямоугольника сверху этого основания для представления нижней части рупорной трубы.

• Черчение двумерного прямоугольника, отображающего апертуру рупора.

• Объединение командой Connect этих двух двумерных объектов для создания трехмерной трубы рупора.

• Объединение основания рупора с рупорной трубой командой Unite.

• Создание воздушной 3D коробки вокруг рупорной антенны.

• Уменьшение размера задачи, путем разрезания структуры на части по двум плоскостям симметрии.

Детальные инструкции для черчения рупорной антенны следуют далее. 

Чтобы подготовиться к черчению рупора, создадим и назовем проект и установим чертежную сетку и единицы.

Замечание. Мы рекомендуем Вам начертить эту структуру самостоятельно по инструкциям, следующим ниже. Однако если Вы не хотите чертить рупорную антенну сразу, Вы можете обратиться к  папке примеров. Название проекта для этого примера  horn.
Создание и обозначение проекта

Чтобы назвать новый проект:

1. Запустите программу. Появляется  окно менеджера проектов.

2. В списке Projects, нажмите New. Появляется окно New Project.

3. Напечатайте имя horntutor в поле New Project.

4. Нажмите OK.

Папка с именем horntutor создана в папке проекта по умолчанию. Эта папка - место, где сохраняются все файлы, которые связаны с этим проектом. Вы можете создавать или изменять папки проекта, если Вы не желаете использовать заданную по умолчанию  папку. 
После задания имени проекта появляется диалоговое окно Project Preferences. 

Установки проекта

Диалоговое окно Project Preferences отображает значения по умолчанию вся-кий раз, когда Вы начинаете новый проект. Это - напоминание, чтобы устано-вить ваши единицы и параметры настройки сетки для вашего проекта.

1. Для этого примера используйте параметры настройки, которые показываются на рис. 2-31. 
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Рис. 2-31. Установки проекта  рупорной антенны

2. Теперь нажмите OK.

Черчение основания рупора

 Чтобы нарисовать рупор, используются команды черчения и команды соедине-ния для создания трехмерных 3D объектов из двух двумерных 2D объектов: дна и верха рупора.

Основание рупора - это параллелепипед с  шириной 0.4 дюйма, длиной 0.9 дюймов и высотой 0.315 дюймов. Чтобы начертить его, создайте 3D параллелепипед  и задайте его размеры.

Для этого:

1. Из основного экрана нажмите Model > Draw.  Отображается экран черчения.

2. Нажмите  3D Objects > Box.

3. Нажмите первую точку в активном окне черчение. Чтобы нарисовать бокс, щелкните мышью снова, чтобы определить противоположный угол бокса. Отображается диалог  шаблона бокса Box Template (рис. 2-32).

4. Заполните шаблон, как на рис. 2-32 и нажмите OK.
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Рис. 2-32. Шаблон прямоугольника для рупорной антенны

В результате получаем основание рупора, показанное на рис. 2-33.
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Рис. 2-33. Основание рупора рупорной антенны

Черчение основания двумерного прямоугольника

Чтобы создать «трубу», или сужающуюся часть рупорной антенны, нарисуем два прямоугольника, и затем соединим их, чтобы создать расширяющуюся трубу. Разместите первый прямоугольник прямо на вершине основания антенны, которую Вы только что чертили.

Для этого сделайте следующие шаги:

1. Нажмите Window > Project Preferences.

2. Нажмите Snap to Object Points, чтобы включить привязку к точкам объекта, а затем нажмите OK.

3. Нажмите 2D Objects > Rectangle.

4. Переместите курсор в один угол основания антенны и нажмите на него.

5. Переместите курсор в противоположный угол основания антенны, и щелкните снова.
    Отображается шаблон прямоугольника. Заметим, что размеры прямоугольника соответствуют размеру основания антенны в плоскости XoY.

6.  Назовите прямоугольник funnel_base и нажмите OK.


[image: image32.png]Origin Dimensions

x[_wo2 ] tengin [ ]

v ] widn [ 0

Pick Paint

€ World Coordinates

@ Local Coordinates

Object Attibutes

Object Name Object Color ™
fomelbere ] = =
Material

a | Use in Simulation
Hetal

=





Рис. 2-34. Двумерный прямоугольник, совпадающий с верхним сечением основания рупора

Отметим, что этот двумерный прямоугольник можно ввести и заполняя диалог рис. 2-34. Он будет нанесен сверху базы антенны. 

Черчение апертуры рупорной антенны

Теперь нарисуем двумерный прямоугольник, который представляет верхнее сечение рупорной антенны, или апертуру рупорной антенны:

1. Нажмите 2D Objects > Rectangle.

2. Переместите курсор куда-нибудь выше бокса, который уже отображен на экране, и кликните для определения угла апертуры.

3. Переместить курсор, чтобы определить противоположную апертуру угла, и щелкните снова. Появляется диалог шаблона прямоугольника.

4.  Заполнить шаблон в диалоге, как на рис. 2-35. После этого нажмите OK.
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Рис. 2-35. Заполнение шаблона прямоугольника апертуры рупорной антенны

Появляется двумерный  прямоугольник, как на рис. 2-36.
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Рис. 2-36. Результат черчения верхнего сечения рупора. Черным отмечен двумерный прямоугольник, указывающий нижнее основание рупора, синим – верхнее основание рупора

Соединение двумерных 2D объектов, чтобы создать трубу

Теперь Вы можете объединить нижнее и верхнее основание рупорной трубы, чтобы создать трехмерный пирамидальный объект.

Чтобы соединить прямоугольники:

1. Нажмите  3D Objects > Connect. Заметим, что в нижнем левом углу текстовой области экрана появляется сообщение с запросом  выбрать двумерный 2D объект: «Select a 2D object».

2. Нажмите на один угол верхнего двумерного объекта, чтобы выбрать его. Затем нажмите на соответствующий ему угол нижнего двумерного объекта, чтобы также выбрать его. Если Вы неправильно выбрали какие-либо точки, нажмите Edit > Undo и осторожно выберите эти точки снова. Появляется диалог шаблона объекта:
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Рис. 2-37. Диалог создания объекта, появляющегося при соединении двух оснований

3. Назовите объект  именем funnel и нажмите OK. Выше основания появляется рупорная труба (рис. 2-38).
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Рис. 2-38. Рупорная антенна

Объединение основания антенны

с рупорной трубой

Хотя это необязательно, объедините два 3D объекта: основание рупорной антенны и трубу, создавая одну 3D структуру рупорной антенны. Это делает задачу более простой,  сводя число объектов к минимуму.

Чтобы объединить основание и трубу:

1. Нажмите 3D Objects > Unite. Появляется диалоговое окно Object Unite.

2.  В списке объектов 3D выберите имена в списке — base и  funnel.

3.  Назовите новый объект именем horn и нажмите OK.
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Рис. 2-39. Диалог объединения двух трехмерных объектов: основания и пирамидальную трубу, из которых состоит рупорная антенна

После этого на экране отображена законченная рупорная антенна. Она не отличается от той,  что была перед объединением (рис. 2-38), но все же объект, названный horn - результат выполнения всех предыдущих шагов.

Заметим, что все 2D и 3D объекты, которые Вы создавали в процессе черчения рупорной антенны, сохраняются с проектом и могут быть отредактированы, чтобы изменить размер и форму рупора, если это будет нужно.

Черчение воздушной 3D коробки  вокруг рупорной антенны

Чтобы рассчитать поле рупорной антенны в дальней зоне, Вы должны поместить её внутрь некоторого объема – бокса, на поверхности которого будут установлены условия излучения. Чтобы начертить воздушную коробку:

1. Нажмите 3D Objects > Box.

2. Начертите прямоугольник в пространстве черчение. Появляется шаблон бокса.

3. Заполните шаблон, как на рис. 2-40 и нажмите OK.
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Рис. 2-40. Шаблон для воздушного бокса Air Box

Вы нарисовали законченную структуру рупорной антенны, как на рис. 2-41.

Сохраните ваш проект  командой File > Save.
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Рис. 2-41. Чертеж законченной рупорной антенны

Разрезание на части структуры
 по двум плоскостям симметрии

Чтобы уменьшить размер задачи, воспользуемся симметрией нашей рупорной антенны. Это сэкономит время и компьютерные ресурсы, решая задачу быстрее и с меньшими размерами файлов.

Рупорная антенна имеет симметрию в двух направлениях — по плоскости Y-Z  антенна имеет электрическую симметрию, а по Z-X  плоскости антенна имеет магнитную симметрию. Поэтому Вы можете рассматривать и решать только одну четверть структуры и соответственно искать поле в объеме, который в четыре раза меньше исходного.

Чтобы разбить на части рупорную антенну, необходимо:

1. Из главного экрана нажать Edit > Slice. Появляется диалоговое окно Object Slice.

2. Выделить курсором, или нажать All Object 3D для  выбора всех объектов для разрезания на части.

3.  Нажать на ZX plane, а затем OK.
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Рис.  2-42. Диалог разрезать объектов по заданной плоскости
Рупорная структура разрезается на части по плоскости Z-X , как на рис. 2-43.
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Рис. 2-43. Срез сектора рупорной антенны по плоскости электрической симметрии Z-X
Заметим, что двумерные объекты (у нас - плоскости оснований рупора) не могут разрезаться на части. На рис. 2-43 Вы  видите, что двумерные объекты, которые Вы чертили, создавая трубу, не разрезались на части.

Поскольку эти объекты не будут включены в моделировании, не имеет значения, что они видимы. Но если Вы желаете сделать чертеж более ясным, Вы можете идти двумя путями:

• Отключить видимость двумерных объектов командой Edit > Visible.
• Стереть двумерные объекты (если  Вы не будете нуждаться в них снова)   командой Edit > Delete.
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Рис.  2-44. Установка режима видимости на чертеже объектов

4. Нажмите на Edit > Slice   снова. Появляется диалоговое окно Object Slice.

5. Нажмите на все объекты 3D.

6. Кликните  на плоскость X-Z  и нажмите OK.

Рупорная структура разрезается на части снова, на сей раз по плоскости X-Z , оставляя только одну четверть структуры, как на рис. 2-45.
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Рис. 2-45. Одна четверть рупорной антенны

Редактирование и стирание рисуемых объектов

Как упомянуто при черчении коаксиального Т-образного соединения, HFSS позволяет Вам редактировать размеры конструкции,  редактируя объекты, которые Вы использовали для черчения.

Нажмите Edit > Object Parameters и выберите объект 2D  или 3D, какой Вы желаете редактировать. Если объект доступен для редактирования, отобража-ется его шаблон с размерами и координатами (рис. 2-46). Тогда  Вы можете изменять значения в любом из полей, которые отображены в шаблоне, и когда Вы нажимаете OK, вы будете видеть результаты изменения в чертеже.
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Рис. 2-46. Диалог редактирования объектов

Однако если объект создан в результате соединения или объединения других объектов, его нельзя редактировать. При соединении двух двумерных объектов, например, Вы можете редактировать исходные 2D объекты, но Вы не можете редактировать сразу 3D структуру, потому, что она - результат использования команды Connect.

Рекомендуется сохранять все 2D  и 3D объекты, из которых Вы создавали другие объекты, пока Вы не уверены, что Вы не будете нуждаться в них снова, чтобы редактировать вашу структуру. Когда Вы уверены, что Вы не нуждаетесь в объектах, которые используются, чтобы создать структуру, сотрите их явно, если Вы желаете,  командой Edit > Delete. Если Вы не стираете их, они сохраняются с проектом.

2.4. Описание материалов

После создания чертежа конструкции, каждому из объектов, включая простран-ство, необходимо задать его материальные свойства. Это выполняется, после черчения и перехода в основное меню командой File/Return to Main.

Как было отмечено в предыдущем разделе, Вы можете задавать материалы, из которых состоят Ваши структуры, сразу после того, как Вы начертили  её. Шаблоны черчения, в которых Вы определяете параметры для 2D или 3D объ-ектов, позволяют Вам задать, будет ли объект включаться в моделирование, а также из какого материала объект выполнен. Материалы, которые перечислены в шаблонах черчения - те, что Вы включили в базу данных материалов. Чтобы задать материал, который отличается от перечисленных в базе данных, исполь-зуется команда главного меню Materials > Assignment. 

Типы материалов

Используйте диалоговое окно Material Assignment, чтобы определить следую-щие типы материалов:

• Металл с потерями или без потерь.

• Изотропный или анизотропный диэлектрик.

• Полупроводник.

• Резистор.

Металл

Объект, который определен как металл, может быть или идеальным проводни-ком или материалом с потерями. Металлы с потерями имеют такое значение проводимости (в См/м), чтобы моделирующее устройство могло сделать точ-ную аппроксимацию поверхностного сопротивления.

Диэлектрик

Объект, который определен как диэлектрик, может быть изотропным (имею-щим однородные свойства во всех направлениях, как корунд) или анизо-тропным,  у которого диэлектрическая проницаемость, магнитная проница-емость, тангенс угла диэлектрических потерь или тангенс угла магнитных потерь изменяются с направлением, так у сапфира. 

Полупроводник

Полупроводник, типа кремния, может быть 2D или 3D объектом. Свойства по-лупроводника определяются или удельным сопротивлением или проводимо-стью. Так как одно из этих значений - всегда обратное другому, то когда Вы вводите одно значение, другое  рассчитывается системой как величина, обрат-ная введенной.

Вы можете также определить магнитную проницаемость и диэлектрическую проницаемость для полупроводников.

Резистор

Резисторы, хотя их свойства сильно зависят от процесса напыления, обычно моделируются как 2D объекты и характеризуются удельным сопротивлением, измеряемым в ом/ квадрат.

Если Вы моделируете резистор как 3D объект, Вы должны  ввести значение удельного сопротивления для него в единицах ом/метр.

Замечания при решении структур с учетом потерь  материалов

Любая структура, которая может анализироваться с учетом потерь, может также рассматриваться как структура без потерь.

Преимущества решения задач с потерями:

• Более точные и достоверные результаты получаются для некоторых классов структур; например, микрополосковых структур с потерями.

• Введение потерь позволяют Вам смоделировать  пассивную нагрузку (резистор), активные нагрузки, оконечные нагрузки и структуры, содержащие неидеальные проводники типа золота или меди. Точно смоделировать такие структуры можно только с учетом потерь.

Примеры

Далее мы определим материалы для рассмотренных ранее  примеров:

• коаксиального Т-образного соединения.

• фильтра на мирополосковой линии.

• рупорной антенны.

Материалы коаксиального Т- образного соединения

Поскольку коаксиальное Т-образное соединение заполнено только воздухом, то легко задать материал для него сразу при черчении структуры. 

Чтобы задать материалы в  примере с  Т-образным соединением, следует:

1. Из диалогового окна менеджера проекта открыть проект coaxtee, если Вы завершили пример черчения в разделе 2.1, или открыть пример коаксиального  Т-образного соединения,  выбирая  папку examples и открывая проект coaxt.

2. Из основного экрана нажмите Materials > Assignment.

Появляется диалоговое окно Material Definition (рис. 2-47).
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Рис. 2-47. Диалоговое окно определения материала коаксиального Т-образного соединения

Заметим, что объект coaxtee перечислен в объектном списке и определен как air (воздух).

3.  В списке материалов проекта (справа) нажмите на air (воздух).

4.  Нажмите Edit Material.

Появляется диалоговое окно Dielectric Definition, рис. 2-48.
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Рис. 2-48. Диалоговое окно определения диэлектрика

Заметим, что воздух определен как материал с диэлектрической проницаемостью, равной 1. Это приблизительная величина.

5. Нажмите Cancel чтобы выйти из диалогового окна.

Материалы микрополоскового фильтра

Фильтр на микрополосковой линии состоит из воздушного бокса, подложки и микрополосковой структуры. Каждый из этих объектов определен как материал, и каждый имеет свой собственный набор характеристик.

Чтобы назначить материалы для фильтра на микрополосковой линии:

1. Откройте проект lpfilter, если Вы завершили пример черчения в Главе 2. Если

Вы не рисовали фильтр на микрополосковой линии, Вы можете открыть при- мер lowpass,  выбирая папку examples и открыть проект ms_lpf.

2.  Из основного экрана нажмите Materials > Assignment.  Появляется диалого-вое окно Material Definition (рис. 2-47).

3. В списке объектов  нажмите  airbox. После этого в списке материалов нажми-
    те на air (воздух).

4. Из списка объектов нажмите dielectric.

5. В поле для имени материала напечатайте alumina (корунд).

6. В списке для типа материала поставьте флажок для диэлектрика.

Поскольку корунд (поликор) имеет одинаковые материальные свойства во всех направлениях, это - изотропный материал. Поэтому Вы не должны ставить флажок anisotropic (анизотропный).

7. Нажмите New Material. Появляется диалоговое окно Dielectric Definition (рис. 2-49).

8. Используйте типичные значения для поликоровой подложки, которые показываются на рис. 2-49.
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Рис. 2-49. Определение диэлектрика как поликора

9. Щелкните OK.

10. В списке объектов нажмите на 2D объект filter. Теперь в списке материалов нажмите на Metal.

11. Кликните Edit Material.  Появляется диалоговое окно Metal Definition.

12. Если Вы вводите реальный проводник, снимите флажок с поля идеального проводника,  нажимая на него.

13.  Заполните значения для проводимости и проницаемости, как на рис. 2-50. После этого нажмите OK.
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Рис. 2-50. Диалоговое окно Metal Definition с параметрами металла для металлической микрополосковой линии

Все материалы для микрополоскового фильтра определены.

Позже Вы определите порты и границы для этой структуры: два порта и плос-кость электрической симметрии по разрезу вдоль микрополоскового фильтра.

В случае проводимости с потерями,  HFSS использует для вычисления поверх-ностного импеданса следующие соотношения: 



,

где ( - проводимость, и ( - относительная магнитная проницаемость.

Материалы рупорной антенны

В примере рупорной антенны и сам рупор, и экранирующая коробка airbox, ко-торая окружает  рупор, составлены из воздуха. Вы могли определить эти объек-ты как воздух, поскольку Вы чертили структуру, или Вы можете определять их теперь как Materials > Assignment.

Чтобы определить материалы для рупорной антенны:

1. Из основного экрана нажмите Materials > Assignment. Появляется диалоговое окно Material Definition (рис. 2-50).

2. Заполните диалоговое окно,  нажимая на каждый 3D объект  (horn и airbox), и нажимая на air как материал для каждого объекта.

3. Щелкните OK.

В следующей главе, когда Вы зададите порты и границы для этой структуры, Вы определите границу излучения  рупора и открытый верх рупора (апертуру), позволяющий структуре излучать в воздушный корпус.
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